{"id":"CVE-2024-3116","state":"PUBLISHED","title":"Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4","description":"pgAdmin <= 8.4 is affected by a  Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.","publishedAt":"2024-04-04T14:59:37.280Z","updatedAt":"2025-03-14T16:35:25.051Z","severity":{"score":7.4,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","source":"PostgreSQL"},"assigner":"PostgreSQL","products":["pgadmin.org pgAdmin 4"],"affected":[{"vendor":"pgadmin.org","product":"pgAdmin 4","defaultStatus":"affected","versions":[{"version":"0","status":"affected","lessThan":"8.5","versionType":"custom"}],"modules":["Utility's Binary Path"],"programFiles":["https://github.com/pgadmin-org/pgadmin4/blob/master/web/pgadmin/misc/__init__.py"],"repo":"https://github.com/pgadmin-org/pgadmin4"}],"references":["https://github.com/pgadmin-org/pgadmin4/issues/7326","https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2/","https://www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-pgadmin-cve-2024-3116"],"weaknesses":["CWE-77"],"ingestedAt":"2026-10-29T20:07:39.287Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/3xxx/CVE-2024-3116.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-3116","state":"PUBLISHED","datePublished":"2024-04-04T14:59:37.280Z","dateUpdated":"2025-03-14T16:35:25.051Z","assignerShortName":"PostgreSQL","assignerOrgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateReserved":"2024-03-30T03:46:32.060Z"},"containers":{"cna":{"title":"Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4","descriptions":[{"lang":"en","value":"pgAdmin <= 8.4 is affected by a  Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data."}],"affected":[{"vendor":"pgadmin.org","product":"pgAdmin 4","defaultStatus":"affected","versions":[{"version":"0","status":"affected","lessThan":"8.5","versionType":"custom"}],"modules":["Utility's Binary Path"],"programFiles":["https://github.com/pgadmin-org/pgadmin4/blob/master/web/pgadmin/misc/__init__.py"],"repo":"https://github.com/pgadmin-org/pgadmin4"}],"references":[{"url":"https://github.com/pgadmin-org/pgadmin4/issues/7326","tags":["issue-tracking"]},{"url":"https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98","tags":["mitigation"]},{"url":"https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2/"}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.4,"baseSeverity":"HIGH","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"providerMetadata":{"shortName":"PostgreSQL","orgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateUpdated":"2024-04-23T02:06:21.997Z"},"datePublic":"2024-03-07T18:30:00.000Z","source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/pgadmin-org/pgadmin4/issues/7326","tags":["issue-tracking","x_transferred"]},{"url":"https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98","tags":["mitigation","x_transferred"]},{"url":"https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2/","tags":["x_transferred"]},{"url":"https://www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-pgadmin-cve-2024-3116"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-19T07:47:48.299Z"}},{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"postgresql","product":"pgadmin_4","defaultStatus":"affected","versions":[{"version":"0","status":"affected","lessThan":"8.5","versionType":"custom"}],"cpes":["cpe:2.3:a:postgresql:pgadmin_4:*:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-04-04T16:40:01.024525Z","id":"CVE-2024-3116","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-77","type":"CWE","lang":"en","description":"CWE-77 Improper Neutralization of Special Elements used in a Command ('Command Injection')"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-14T16:35:25.051Z"}}]}}}