{"id":"CVE-2024-30425","state":"PUBLISHED","title":"WordPress Beaver Builder plugin <= 2.7.4.4 - Cross Site Scripting (XSS) vulnerability","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Beaver Builder Beaver Builder beaver-builder-lite-version allows DOM-Based XSS.This issue affects Beaver Builder: from n/a through <= 2.7.4.4.","publishedAt":"2024-03-29T13:19:15.872Z","updatedAt":"2026-04-28T16:09:22.962Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["Beaver Builder Beaver Builder"],"affected":[{"vendor":"Beaver Builder","product":"Beaver Builder","packageName":"beaver-builder-lite-version","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.7.4.4","changes":[{"at":"2.7.4.5","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/Wordpress/Plugin/beaver-builder-lite-version/vulnerability/wordpress-beaver-builder-wordpress-page-builder-plugin-2-7-4-4-cross-site-scripting-xss-vulnerability?_s_id=cve","https://patchstack.com/database/vulnerability/beaver-builder-lite-version/wordpress-beaver-builder-wordpress-page-builder-plugin-2-7-4-4-cross-site-scripting-xss-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:21.467Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/30xxx/CVE-2024-30425.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-30425","state":"PUBLISHED","datePublished":"2024-03-29T13:19:15.872Z","dateUpdated":"2026-04-28T16:09:22.962Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2024-03-27T05:57:07.765Z"},"containers":{"cna":{"title":"WordPress Beaver Builder plugin <= 2.7.4.4 - Cross Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Beaver Builder Beaver Builder beaver-builder-lite-version allows DOM-Based XSS.This issue affects Beaver Builder: from n/a through <= 2.7.4.4."}],"affected":[{"vendor":"Beaver Builder","product":"Beaver Builder","packageName":"beaver-builder-lite-version","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.7.4.4","changes":[{"at":"2.7.4.5","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/Wordpress/Plugin/beaver-builder-lite-version/vulnerability/wordpress-beaver-builder-wordpress-page-builder-plugin-2-7-4-4-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:09:22.962Z"},"credits":[{"lang":"en","type":"finder","value":"Abu Hurayra | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:24:07.636Z","impacts":[{"capecId":"CAPEC-588","descriptions":[{"lang":"en","value":"DOM-Based XSS"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-03-29T14:52:30.577698Z","id":"CVE-2024-30425","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-19T14:33:28.537Z"}},{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/database/vulnerability/beaver-builder-lite-version/wordpress-beaver-builder-wordpress-page-builder-plugin-2-7-4-4-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T01:32:07.363Z"}}]}}}