{"id":"CVE-2024-2401","state":"PUBLISHED","title":"Admin Page Spider <= 3.31 -  Authenticated (Admin+) Stored Cross-Site Scripting","description":"The Admin Page Spider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.31 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2024-05-02T16:52:35.790Z","updatedAt":"2026-04-08T17:20:21.048Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["jatacid Admin Page Spider"],"affected":[{"vendor":"jatacid","product":"Admin Page Spider","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.31","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c33d9295-0c7f-45a0-9d62-4293c8bbef0b?source=cve","https://wordpress.org/plugins/admin-page-spider/","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3087069%40admin-page-spider&new=3087069%40admin-page-spider&sfp_email=&sfph_mail="],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:07:21.467Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/2xxx/CVE-2024-2401.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-2401","state":"PUBLISHED","datePublished":"2024-05-02T16:52:35.790Z","dateUpdated":"2026-04-08T17:20:21.048Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-03-12T12:24:37.825Z"},"containers":{"cna":{"title":"Admin Page Spider <= 3.31 -  Authenticated (Admin+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Admin Page Spider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.31 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"jatacid","product":"Admin Page Spider","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.31","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c33d9295-0c7f-45a0-9d62-4293c8bbef0b?source=cve"},{"url":"https://wordpress.org/plugins/admin-page-spider/"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3087069%40admin-page-spider&new=3087069%40admin-page-spider&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:20:21.048Z"},"credits":[{"lang":"en","type":"finder","value":"Dikshita Trivedi"}],"timeline":[{"time":"2024-04-29T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-2401","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-05-02T19:22:50.020229Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-06-04T17:29:27.363Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c33d9295-0c7f-45a0-9d62-4293c8bbef0b?source=cve","tags":["x_transferred"]},{"url":"https://wordpress.org/plugins/admin-page-spider/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T19:11:53.390Z"}}]}}}