{"id":"CVE-2024-21543","state":"PUBLISHED","title":"Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the da","description":"Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS.","publishedAt":"2024-12-13T05:00:16.747Z","updatedAt":"2025-02-20T22:02:38.155Z","severity":{"score":5.7,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","source":"snyk"},"assigner":"snyk","products":["n/a djoser"],"affected":[{"vendor":"n/a","product":"djoser","versions":[{"version":"0","status":"affected","lessThan":"2.3.0","versionType":"semver"}]}],"references":["https://security.snyk.io/vuln/SNYK-PYTHON-DJOSER-8366540","https://github.com/sunscrapers/djoser/releases/tag/2.3.0","https://github.com/sunscrapers/djoser/issues/795","https://github.com/sunscrapers/djoser/pull/819","https://github.com/sunscrapers/djoser/commit/d33c3993c0c735f23cbedc60fa59fce69354f19d","https://lists.debian.org/debian-lts-announce/2025/02/msg00023.html"],"weaknesses":["CWE-287","CWE-295"],"ingestedAt":"2026-10-29T20:06:59.846Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/21xxx/CVE-2024-21543.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-21543","state":"PUBLISHED","datePublished":"2024-12-13T05:00:16.747Z","dateUpdated":"2025-02-20T22:02:38.155Z","assignerShortName":"snyk","assignerOrgId":"bae035ff-b466-4ff4-94d0-fc9efd9e1730","dateReserved":"2023-12-22T12:33:20.124Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS."}],"affected":[{"vendor":"n/a","product":"djoser","versions":[{"version":"0","status":"affected","lessThan":"2.3.0","versionType":"semver"}]}],"references":[{"url":"https://security.snyk.io/vuln/SNYK-PYTHON-DJOSER-8366540"},{"url":"https://github.com/sunscrapers/djoser/releases/tag/2.3.0"},{"url":"https://github.com/sunscrapers/djoser/issues/795"},{"url":"https://github.com/sunscrapers/djoser/pull/819"},{"url":"https://github.com/sunscrapers/djoser/commit/d33c3993c0c735f23cbedc60fa59fce69354f19d"}],"metrics":[{"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"LOW","availabilityImpact":"NONE","baseScore":7.1,"baseSeverity":"HIGH","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N/E:P"},"cvssV4_0":{"version":"4.0","attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"LOW","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":5.7,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","description":"Authentication Bypass","lang":"en"}]}],"providerMetadata":{"shortName":"snyk","orgId":"bae035ff-b466-4ff4-94d0-fc9efd9e1730","dateUpdated":"2024-12-13T05:00:16.747Z"},"credits":[{"value":"Diego Cebrian","lang":"en"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-13T19:53:42.470510Z","id":"CVE-2024-21543","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-295","type":"CWE","lang":"en","description":"CWE-295 Improper Certificate Validation"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-13T19:54:55.397Z"}},{"title":"CVE Program Container","references":[{"url":"https://lists.debian.org/debian-lts-announce/2025/02/msg00023.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-02-20T22:02:38.155Z"}}]}}}