{"id":"CVE-2024-1808","state":"PUBLISHED","title":"WP Shortcodes Plugin — Shortcodes Ultimate <= 7.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via su_qrcode Shortcode","description":"The WP Shortcodes Plugin — Shortcodes Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'su_qrcode' shortcode in all versions up to, and including, 7.0.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-02-28T12:50:50.204Z","updatedAt":"2026-04-08T17:10:15.156Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["gn_themes WP Shortcodes Plugin — Shortcodes Ultimate"],"affected":[{"vendor":"gn_themes","product":"WP Shortcodes Plugin — Shortcodes Ultimate","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/96769a0e-d4a9-4196-8ded-b600046c0943?source=cve","https://plugins.trac.wordpress.org/changeset/3041647/shortcodes-ultimate"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:59.846Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/1xxx/CVE-2024-1808.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-1808","state":"PUBLISHED","datePublished":"2024-02-28T12:50:50.204Z","dateUpdated":"2026-04-08T17:10:15.156Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-02-22T22:00:45.914Z"},"containers":{"cna":{"title":"WP Shortcodes Plugin — Shortcodes Ultimate <= 7.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via su_qrcode Shortcode","descriptions":[{"lang":"en","value":"The WP Shortcodes Plugin — Shortcodes Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'su_qrcode' shortcode in all versions up to, and including, 7.0.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"gn_themes","product":"WP Shortcodes Plugin — Shortcodes Ultimate","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/96769a0e-d4a9-4196-8ded-b600046c0943?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3041647/shortcodes-ultimate"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:10:15.156Z"},"credits":[{"lang":"en","type":"finder","value":"Craig Smith"}],"timeline":[{"time":"2024-02-22T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2024-02-27T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/96769a0e-d4a9-4196-8ded-b600046c0943?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/3041647/shortcodes-ultimate","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-01T18:48:22.046Z"}},{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"mythemeshop","product":"wp_shortcode","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0.3","versionType":"semver"}],"cpes":["cpe:2.3:a:mythemeshop:wp_shortcode:*:*:*:*:*:wordpress:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-08-02T19:30:52.394429Z","id":"CVE-2024-1808","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-08-02T19:33:14.438Z"}}]}}}