{"id":"CVE-2024-14030","state":"PUBLISHED","title":"Sereal::Decoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library","description":"Sereal::Decoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library.\n\nSereal::Decoder embeds a version of the Zstandard (zstd) library that is vulnerable to CVE-2019-11922.  This is a race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.","publishedAt":"2026-03-31T11:31:08.541Z","updatedAt":"2026-04-01T16:29:33.903Z","severity":{"score":8.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","source":"CISA-ADP"},"assigner":"CPANSec","products":["YVES Sereal::Decoder"],"affected":[{"vendor":"YVES","product":"Sereal::Decoder","packageName":"Sereal-Decoder","defaultStatus":"unaffected","versions":[{"version":"4.000","status":"affected","lessThanOrEqual":"4.009_002","versionType":"custom"}],"collectionURL":"https://cpan.org/modules","repo":"https://github.com/Sereal/Sereal"}],"references":["https://github.com/advisories/GHSA-w77f-wv46-4vcx","https://www.cve.org/CVERecord?id=CVE-2019-11922","https://metacpan.org/release/YVES/Sereal-Decoder-4.010/changes"],"weaknesses":["CWE-1395"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/14xxx/CVE-2024-14030.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-14030","state":"PUBLISHED","datePublished":"2026-03-31T11:31:08.541Z","dateUpdated":"2026-04-01T16:29:33.903Z","assignerShortName":"CPANSec","assignerOrgId":"9b29abf9-4ab0-4765-b253-1875cd9b441e","dateReserved":"2026-03-28T19:49:07.023Z"},"containers":{"cna":{"title":"Sereal::Decoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library","descriptions":[{"lang":"en","value":"Sereal::Decoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library.\n\nSereal::Decoder embeds a version of the Zstandard (zstd) library that is vulnerable to CVE-2019-11922.  This is a race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used."}],"affected":[{"vendor":"YVES","product":"Sereal::Decoder","packageName":"Sereal-Decoder","defaultStatus":"unaffected","versions":[{"version":"4.000","status":"affected","lessThanOrEqual":"4.009_002","versionType":"custom"}],"collectionURL":"https://cpan.org/modules","repo":"https://github.com/Sereal/Sereal"}],"references":[{"url":"https://github.com/advisories/GHSA-w77f-wv46-4vcx","tags":["vendor-advisory"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2019-11922","tags":["vendor-advisory"]},{"url":"https://metacpan.org/release/YVES/Sereal-Decoder-4.010/changes","tags":["release-notes"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-1395","description":"CWE-1395 Dependency on Vulnerable Third-Party Component","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"CPANSec","orgId":"9b29abf9-4ab0-4765-b253-1875cd9b441e","dateUpdated":"2026-04-01T16:29:33.903Z"},"solutions":[{"lang":"en","value":"Upgrade to Sereal::Decoder version 4.010 or later."}],"source":{"discovery":"UNKNOWN"},"timeline":[{"lang":"en","time":"2017-02-06T00:00:00.000Z","value":"Sereal::Decoder version 4.001_001 released."},{"lang":"en","time":"2018-12-27T00:00:00.000Z","value":"Zstandard 1.3.8 released."},{"lang":"en","time":"2019-07-25T00:00:00.000Z","value":"CVE-2019-11922 for Zstandard published"},{"lang":"en","time":"2020-02-04T00:00:00.000Z","value":"Sereal::Decoder version 4.010 released."},{"lang":"en","time":"2023-02-09T00:00:00.000Z","value":"Advisory added to the CPANSA database."},{"lang":"en","time":"2024-02-17T00:00:00.000Z","value":"Advisory updated in the CPANSA database."}],"x_generator":{"engine":"cpansec-cna-tool 0.1"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"UNCHANGED","version":"3.1","baseScore":8.1,"attackVector":"NETWORK","baseSeverity":"HIGH","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","integrityImpact":"HIGH","userInteraction":"NONE","attackComplexity":"HIGH","availabilityImpact":"HIGH","privilegesRequired":"NONE","confidentialityImpact":"HIGH"}},{"other":{"type":"ssvc","content":{"timestamp":"2026-03-31T14:18:18.323057Z","id":"CVE-2024-14030","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-1395","type":"CWE","lang":"en","description":"CWE-1395 Dependency on Vulnerable Third-Party Component"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-03-31T14:18:55.221Z"}}]}}}