{"id":"CVE-2024-13644","state":"PUBLISHED","title":"DethemeKit For Elementor <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via De Gallery Widget","description":"The DethemeKit For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's De Gallery widget in all versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-02-13T01:44:53.214Z","updatedAt":"2026-04-08T16:54:12.694Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["detheme DethemeKit for Elementor"],"affected":[{"vendor":"detheme","product":"DethemeKit for Elementor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.8","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/56ac720a-db1e-4aca-b12c-5289fa7b8b9e?source=cve","https://plugins.trac.wordpress.org/changeset/3236114/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/13xxx/CVE-2024-13644.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13644","state":"PUBLISHED","datePublished":"2025-02-13T01:44:53.214Z","dateUpdated":"2026-04-08T16:54:12.694Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-01-23T01:05:35.345Z"},"containers":{"cna":{"title":"DethemeKit For Elementor <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via De Gallery Widget","descriptions":[{"lang":"en","value":"The DethemeKit For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's De Gallery widget in all versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"detheme","product":"DethemeKit for Elementor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.8","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/56ac720a-db1e-4aca-b12c-5289fa7b8b9e?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3236114/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:54:12.694Z"},"credits":[{"lang":"en","type":"finder","value":"D.Sim"}],"timeline":[{"time":"2025-01-23T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-02-12T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-13T19:42:04.611725Z","id":"CVE-2024-13644","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-13T19:42:27.933Z"}}]}}}