{"id":"CVE-2024-13637","state":"PUBLISHED","title":"Demo Awesome <= 1.0.3 - Missing Authorization to Authenticated (Subscriber+) Plugin Activation","description":"The Demo Awesome plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the install_plugin function in all versions up to, and including, 1.0.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins..","publishedAt":"2025-04-02T09:21:44.774Z","updatedAt":"2026-04-08T17:11:02.547Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["romik84 Demo Awesome"],"affected":[{"vendor":"romik84","product":"Demo Awesome","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/9a552f81-b222-46f0-b318-702e09d249c1?source=cve","https://plugins.trac.wordpress.org/browser/demo-awesome/trunk/inc/admin/js/admin.js#L1684","https://wordpress.org/plugins/demo-awesome/#developers","https://plugins.trac.wordpress.org/browser/demo-awesome/trunk/inc/admin/class-demo-awesome-admin.php#L407"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/13xxx/CVE-2024-13637.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13637","state":"PUBLISHED","datePublished":"2025-04-02T09:21:44.774Z","dateUpdated":"2026-04-08T17:11:02.547Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-01-22T22:31:47.921Z"},"containers":{"cna":{"title":"Demo Awesome <= 1.0.3 - Missing Authorization to Authenticated (Subscriber+) Plugin Activation","descriptions":[{"lang":"en","value":"The Demo Awesome plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the install_plugin function in all versions up to, and including, 1.0.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins.."}],"affected":[{"vendor":"romik84","product":"Demo Awesome","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/9a552f81-b222-46f0-b318-702e09d249c1?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/demo-awesome/trunk/inc/admin/js/admin.js#L1684"},{"url":"https://wordpress.org/plugins/demo-awesome/#developers"},{"url":"https://plugins.trac.wordpress.org/browser/demo-awesome/trunk/inc/admin/class-demo-awesome-admin.php#L407"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:11:02.547Z"},"credits":[{"lang":"en","type":"finder","value":"Krzysztof Zając"}],"timeline":[{"time":"2025-04-01T20:30:16.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-02T14:37:42.825783Z","id":"CVE-2024-13637","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-02T14:41:10.536Z"}}]}}}