{"id":"CVE-2024-13560","state":"PUBLISHED","title":"Subscriptions & Memberships for PayPal <= 1.1.6 - Cross-Site Request Forgery to Arbitrary Post Deletion","description":"The Subscriptions & Memberships for PayPal plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.6. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to delete arbitrary posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-02-26T08:21:56.395Z","updatedAt":"2026-04-08T16:43:46.736Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["scottpaterson Subscriptions & Memberships for PayPal"],"affected":[{"vendor":"scottpaterson","product":"Subscriptions & Memberships for PayPal","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/2bed7fc8-a961-4141-80a1-9c23a6504fbd?source=cve","https://wordpress.org/plugins/subscriptions-memberships-for-paypal/#developers","https://plugins.trac.wordpress.org/changeset/3246039/subscriptions-memberships-for-paypal"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/13xxx/CVE-2024-13560.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13560","state":"PUBLISHED","datePublished":"2025-02-26T08:21:56.395Z","dateUpdated":"2026-04-08T16:43:46.736Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-01-20T22:55:52.534Z"},"containers":{"cna":{"title":"Subscriptions & Memberships for PayPal <= 1.1.6 - Cross-Site Request Forgery to Arbitrary Post Deletion","descriptions":[{"lang":"en","value":"The Subscriptions & Memberships for PayPal plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.6. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to delete arbitrary posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"scottpaterson","product":"Subscriptions & Memberships for PayPal","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/2bed7fc8-a961-4141-80a1-9c23a6504fbd?source=cve"},{"url":"https://wordpress.org/plugins/subscriptions-memberships-for-paypal/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3246039/subscriptions-memberships-for-paypal"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:43:46.736Z"},"credits":[{"lang":"en","type":"finder","value":"Krzysztof Zając"}],"timeline":[{"time":"2025-02-25T19:40:01.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-26T14:46:48.532370Z","id":"CVE-2024-13560","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-26T15:34:07.785Z"}}]}}}