{"id":"CVE-2024-13518","state":"PUBLISHED","title":"Simple:Press <= 6.10.12 - Cross-Site Request Forgery to Unauthorized Post Editing","description":"The Simple:Press Forum plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.10.12. This is due to missing or incorrect nonce validation on the 'sp_save_edited_post' function. This makes it possible for unauthenticated attackers to modify a forum post via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-03-01T04:21:49.340Z","updatedAt":"2026-04-08T16:49:23.963Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["simplepress Simple:Press Forum"],"affected":[{"vendor":"simplepress","product":"Simple:Press Forum","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.10.12","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/4484fa86-5878-426d-92b9-8eb0751075e5?source=cve","https://plugins.trac.wordpress.org/browser/simplepress/trunk/forum/database/sp-db-management.php#L173","https://plugins.trac.wordpress.org/changeset/3251363"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/13xxx/CVE-2024-13518.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13518","state":"PUBLISHED","datePublished":"2025-03-01T04:21:49.340Z","dateUpdated":"2026-04-08T16:49:23.963Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-01-17T18:26:44.327Z"},"containers":{"cna":{"title":"Simple:Press <= 6.10.12 - Cross-Site Request Forgery to Unauthorized Post Editing","descriptions":[{"lang":"en","value":"The Simple:Press Forum plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.10.12. This is due to missing or incorrect nonce validation on the 'sp_save_edited_post' function. This makes it possible for unauthenticated attackers to modify a forum post via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"simplepress","product":"Simple:Press Forum","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.10.12","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/4484fa86-5878-426d-92b9-8eb0751075e5?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/simplepress/trunk/forum/database/sp-db-management.php#L173"},{"url":"https://plugins.trac.wordpress.org/changeset/3251363"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:49:23.963Z"},"credits":[{"lang":"en","type":"finder","value":"Robert Subotic"}],"timeline":[{"time":"2025-02-28T15:24:11.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-03T16:01:02.757818Z","id":"CVE-2024-13518","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-03T17:38:54.728Z"}}]}}}