{"id":"CVE-2024-13487","state":"PUBLISHED","title":"CURCY – Multi Currency for WooCommerce <= 2.2.5 - Unauthenticated Arbitrary Shortcode Execution via get_products_price Function","description":"The The CURCY – Multi Currency for WooCommerce – The best free currency exchange plugin – Run smoothly on WooCommerce 9.x plugin for WordPress is vulnerable to arbitrary shortcode execution via the get_products_price() function in all versions up to, and including, 2.2.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.","publishedAt":"2025-02-06T06:53:40.819Z","updatedAt":"2026-06-03T14:25:41.033Z","severity":{"score":7.3,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","source":"Wordfence"},"assigner":"Wordfence","products":["villatheme CURCY – Multi Currency for WooCommerce – Smoothly on WooCommerce 9.x"],"affected":[{"vendor":"villatheme","product":"CURCY – Multi Currency for WooCommerce – Smoothly on WooCommerce 9.x","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.2.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/d630dd85-0169-4582-a8ae-54e5053425ac?source=cve","https://plugins.trac.wordpress.org/browser/woo-multi-currency/trunk/frontend/cache.php#L60","https://wordpress.org/plugins/woo-multi-currency/#developers","https://plugins.trac.wordpress.org/changeset/3234505/"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/13xxx/CVE-2024-13487.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13487","state":"PUBLISHED","datePublished":"2025-02-06T06:53:40.819Z","dateUpdated":"2026-06-03T14:25:41.033Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-01-16T19:08:17.265Z"},"containers":{"cna":{"title":"CURCY – Multi Currency for WooCommerce <= 2.2.5 - Unauthenticated Arbitrary Shortcode Execution via get_products_price Function","descriptions":[{"lang":"en","value":"The The CURCY – Multi Currency for WooCommerce – The best free currency exchange plugin – Run smoothly on WooCommerce 9.x plugin for WordPress is vulnerable to arbitrary shortcode execution via the get_products_price() function in all versions up to, and including, 2.2.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes."}],"affected":[{"vendor":"villatheme","product":"CURCY – Multi Currency for WooCommerce – Smoothly on WooCommerce 9.x","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.2.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/d630dd85-0169-4582-a8ae-54e5053425ac?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/woo-multi-currency/trunk/frontend/cache.php#L60"},{"url":"https://wordpress.org/plugins/woo-multi-currency/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3234505/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","baseScore":7.3,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:26:17.368Z"},"credits":[{"lang":"en","type":"finder","value":"Michael Mazzolini"}],"timeline":[{"time":"2025-02-05T18:44:02.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-06T14:31:03.556149Z","id":"CVE-2024-13487","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-06-03T14:25:41.033Z"}}]}}}