{"id":"CVE-2024-12634","state":"PUBLISHED","title":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins <= 2.0.59 - Cross-Site Request Forgery to Stored Cross-Site Scripting","description":"The Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including 2.0.59. This is due to missing nonce validation on a function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-03-07T11:12:54.726Z","updatedAt":"2025-03-07T14:35:57.162Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["pickplugins Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins"],"affected":[{"vendor":"pickplugins","product":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins","defaultStatus":"unaffected","versions":[{"version":"2.0.59","status":"affected"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/29d22612-8e0d-4275-b370-9729352c951e?source=cve","https://plugins.trac.wordpress.org/browser/related-post/tags/2.0.58b/includes/menu/settings.php#L129","https://wordpress.org/plugins/related-post/#developers","https://plugins.trac.wordpress.org/changeset/3251482/"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/12xxx/CVE-2024-12634.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-12634","state":"PUBLISHED","datePublished":"2025-03-07T11:12:54.726Z","dateUpdated":"2025-03-07T14:35:57.162Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-12-13T21:32:42.319Z"},"containers":{"cna":{"title":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins <= 2.0.59 - Cross-Site Request Forgery to Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including 2.0.59. This is due to missing nonce validation on a function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"pickplugins","product":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins","defaultStatus":"unaffected","versions":[{"version":"2.0.59","status":"affected"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/29d22612-8e0d-4275-b370-9729352c951e?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/related-post/tags/2.0.58b/includes/menu/settings.php#L129"},{"url":"https://wordpress.org/plugins/related-post/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3251482/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2025-03-07T11:12:54.726Z"},"credits":[{"lang":"en","type":"finder","value":"Dale Mavers"}],"timeline":[{"time":"2025-03-06T21:30:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-07T14:34:47.196215Z","id":"CVE-2024-12634","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-07T14:35:57.162Z"}}]}}}