{"id":"CVE-2024-12509","state":"PUBLISHED","title":"Embed Twine <= 0.1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Embed Twine plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'embed_twine' shortcode in all versions up to, and including, 0.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-12-20T06:59:06.967Z","updatedAt":"2026-04-08T16:57:35.542Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["rluks Embed Twine"],"affected":[{"vendor":"rluks","product":"Embed Twine","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/647f0b46-ac12-445b-9d41-66eba3eb2b1a?source=cve","https://wordpress.org/plugins/embed-twine/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/12xxx/CVE-2024-12509.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-12509","state":"PUBLISHED","datePublished":"2024-12-20T06:59:06.967Z","dateUpdated":"2026-04-08T16:57:35.542Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-12-11T13:23:08.457Z"},"containers":{"cna":{"title":"Embed Twine <= 0.1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Embed Twine plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'embed_twine' shortcode in all versions up to, and including, 0.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"rluks","product":"Embed Twine","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/647f0b46-ac12-445b-9d41-66eba3eb2b1a?source=cve"},{"url":"https://wordpress.org/plugins/embed-twine/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:57:35.542Z"},"credits":[{"lang":"en","type":"finder","value":"SOPROBRO"}],"timeline":[{"time":"2024-12-19T18:04:28.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-20T15:59:49.577580Z","id":"CVE-2024-12509","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-20T16:00:17.295Z"}}]}}}