{"id":"CVE-2024-12444","state":"PUBLISHED","title":"WP Dispensary <= 4.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The WP Dispensary plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpd_menu' shortcode in all versions up to, and including, 4.5.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-01-30T13:41:55.693Z","updatedAt":"2026-04-08T16:36:39.336Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["deviodigital WP Dispensary"],"affected":[{"vendor":"deviodigital","product":"WP Dispensary","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.5.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/13753c4d-1b51-4db2-a69e-523857a50e55?source=cve","https://plugins.trac.wordpress.org/browser/wp-dispensary/trunk/admin/wp-dispensary-shortcodes.php#L256","https://wordpress.org/plugins/wp-dispensary"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/12xxx/CVE-2024-12444.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-12444","state":"PUBLISHED","datePublished":"2025-01-30T13:41:55.693Z","dateUpdated":"2026-04-08T16:36:39.336Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-12-10T19:07:04.323Z"},"containers":{"cna":{"title":"WP Dispensary <= 4.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP Dispensary plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpd_menu' shortcode in all versions up to, and including, 4.5.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"deviodigital","product":"WP Dispensary","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.5.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/13753c4d-1b51-4db2-a69e-523857a50e55?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-dispensary/trunk/admin/wp-dispensary-shortcodes.php#L256"},{"url":"https://wordpress.org/plugins/wp-dispensary"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:36:39.336Z"},"credits":[{"lang":"en","type":"finder","value":"Djaidja Moundjid"}],"timeline":[{"time":"2025-01-30T00:42:16.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-30T14:54:15.567655Z","id":"CVE-2024-12444","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-30T14:54:20.217Z"}}]}}}