{"id":"CVE-2024-12271","state":"PUBLISHED","title":"360 Javascript Viewer <= 1.7.29 - Authenticated (Administrator+) Stored Cross-Site Scripting","description":"The 360 Javascript Viewer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘ref’ parameter in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2024-12-12T12:42:13.571Z","updatedAt":"2026-04-08T16:36:29.969Z","severity":{"score":4.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["jtermaat 360 Javascript Viewer"],"affected":[{"vendor":"jtermaat","product":"360 Javascript Viewer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.7.29","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/12b4e363-248f-469a-a958-0b1ec5c6e37f?source=cve","https://plugins.trac.wordpress.org/browser/360deg-javascript-viewer/trunk/includes/class-jsv-360-parser.php#L129","https://plugins.trac.wordpress.org/browser/360deg-javascript-viewer/trunk/includes/class-jsv-360-parser.php#L162","https://plugins.trac.wordpress.org/changeset/3206400/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/12xxx/CVE-2024-12271.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-12271","state":"PUBLISHED","datePublished":"2024-12-12T12:42:13.571Z","dateUpdated":"2026-04-08T16:36:29.969Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-12-05T18:05:17.835Z"},"containers":{"cna":{"title":"360 Javascript Viewer <= 1.7.29 - Authenticated (Administrator+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The 360 Javascript Viewer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘ref’ parameter in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"jtermaat","product":"360 Javascript Viewer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.7.29","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/12b4e363-248f-469a-a958-0b1ec5c6e37f?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/360deg-javascript-viewer/trunk/includes/class-jsv-360-parser.php#L129"},{"url":"https://plugins.trac.wordpress.org/browser/360deg-javascript-viewer/trunk/includes/class-jsv-360-parser.php#L162"},{"url":"https://plugins.trac.wordpress.org/changeset/3206400/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:36:29.969Z"},"credits":[{"lang":"en","type":"finder","value":"Yamil Rosa"}],"timeline":[{"time":"2024-12-11T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-12T14:25:06.381342Z","id":"CVE-2024-12271","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-12T14:25:59.433Z"}}]}}}