{"id":"CVE-2024-12031","state":"PUBLISHED","title":"Advanced Floating Content <= 3.8.2 - Authenticated (Subscriber+) SQL Injection","description":"The Advanced Floating Content plugin for WordPress is vulnerable to SQL Injection via the 'floating_content_duplicate_post' function in all versions up to, and including, 3.8.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query.  This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.","publishedAt":"2024-12-24T09:21:50.597Z","updatedAt":"2026-04-08T17:09:26.690Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["CodeTides Advanced Floating Content"],"affected":[{"vendor":"CodeTides","product":"Advanced Floating Content","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.8.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/927076bc-bafa-43d6-bf3b-5861844c932a?source=cve","https://codecanyon.net/item/advanced-floating-content/9945856"],"weaknesses":["CWE-89"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/12xxx/CVE-2024-12031.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-12031","state":"PUBLISHED","datePublished":"2024-12-24T09:21:50.597Z","dateUpdated":"2026-04-08T17:09:26.690Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-12-02T15:42:42.917Z"},"containers":{"cna":{"title":"Advanced Floating Content <= 3.8.2 - Authenticated (Subscriber+) SQL Injection","descriptions":[{"lang":"en","value":"The Advanced Floating Content plugin for WordPress is vulnerable to SQL Injection via the 'floating_content_duplicate_post' function in all versions up to, and including, 3.8.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query.  This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database."}],"affected":[{"vendor":"CodeTides","product":"Advanced Floating Content","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.8.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/927076bc-bafa-43d6-bf3b-5861844c932a?source=cve"},{"url":"https://codecanyon.net/item/advanced-floating-content/9945856"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-89","lang":"en","description":"CWE-89 Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:09:26.690Z"},"credits":[{"lang":"en","type":"finder","value":"Thái An"}],"timeline":[{"time":"2024-12-23T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-24T15:18:12.442348Z","id":"CVE-2024-12031","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-24T15:18:19.920Z"}}]}}}