{"id":"CVE-2024-11929","state":"PUBLISHED","title":"Responsive FlipBook Plugin Wordpress <= 2.5.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting","description":"The Responsive FlipBook Plugin Wordpress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the rfbwp_save_settings() functionin all versions up to, and including, 2.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-01-09T11:10:58.270Z","updatedAt":"2026-04-08T16:53:08.860Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["mpc Responsive FlipBook Plugin Wordpress"],"affected":[{"vendor":"mpc","product":"Responsive FlipBook Plugin Wordpress","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/53b24f9a-f225-40b5-9937-f7449d4832df?source=cve","https://codecanyon.net/item/responsive-flipbook-plugin/2372863"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/11xxx/CVE-2024-11929.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11929","state":"PUBLISHED","datePublished":"2025-01-09T11:10:58.270Z","dateUpdated":"2026-04-08T16:53:08.860Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-27T19:49:39.902Z"},"containers":{"cna":{"title":"Responsive FlipBook Plugin Wordpress <= 2.5.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Responsive FlipBook Plugin Wordpress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the rfbwp_save_settings() functionin all versions up to, and including, 2.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"mpc","product":"Responsive FlipBook Plugin Wordpress","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.5.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/53b24f9a-f225-40b5-9937-f7449d4832df?source=cve"},{"url":"https://codecanyon.net/item/responsive-flipbook-plugin/2372863"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:53:08.860Z"},"credits":[{"lang":"en","type":"finder","value":"Tieu Pham Trong Nhan"},{"lang":"en","type":"finder","value":"tptNhan"}],"timeline":[{"time":"2025-01-08T22:07:27.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-09T14:48:22.026598Z","id":"CVE-2024-11929","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-09T14:48:31.903Z"}}]}}}