{"id":"CVE-2024-11761","state":"PUBLISHED","title":"LegalWeb Cloud <= 1.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The LegalWeb Cloud plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'legalweb-popup' shortcode in all versions up to, and including, 1.1.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-11-28T08:47:29.472Z","updatedAt":"2026-04-08T16:32:51.916Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["legalweb LegalWeb Cloud"],"affected":[{"vendor":"legalweb","product":"LegalWeb Cloud","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/034d3d52-cb77-40dd-85a1-81ca3bfd1f23?source=cve","https://plugins.trac.wordpress.org/changeset/3198065/legalweb-cloud/trunk/includes/shortcodes/class-legalweb-cloud-cookie-popup-shortcode.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/11xxx/CVE-2024-11761.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11761","state":"PUBLISHED","datePublished":"2024-11-28T08:47:29.472Z","dateUpdated":"2026-04-08T16:32:51.916Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-26T15:00:42.970Z"},"containers":{"cna":{"title":"LegalWeb Cloud <= 1.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The LegalWeb Cloud plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'legalweb-popup' shortcode in all versions up to, and including, 1.1.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"legalweb","product":"LegalWeb Cloud","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/034d3d52-cb77-40dd-85a1-81ca3bfd1f23?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3198065/legalweb-cloud/trunk/includes/shortcodes/class-legalweb-cloud-cookie-popup-shortcode.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:32:51.916Z"},"credits":[{"lang":"en","type":"finder","value":"SOPROBRO"}],"timeline":[{"time":"2024-11-27T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-11761","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-11-28T12:24:49.078186Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-28T12:25:17.653Z"}}]}}}