{"id":"CVE-2024-11457","state":"PUBLISHED","title":"Feedpress Generator – External RSS Frontend Customizer <= 1.2.1 - Reflected Cross-Site Scripting","description":"The Feedpress Generator – External RSS Frontend Customizer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","publishedAt":"2024-12-07T11:09:54.038Z","updatedAt":"2026-04-08T17:34:09.858Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["spartac Feedpress Generator – External RSS Frontend Customizer"],"affected":[{"vendor":"spartac","product":"Feedpress Generator – External RSS Frontend Customizer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/f9660aee-1069-4197-b166-12ea30f8fd0c?source=cve","https://wordpress.org/plugins/feedpress-generator/#developers"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/11xxx/CVE-2024-11457.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11457","state":"PUBLISHED","datePublished":"2024-12-07T11:09:54.038Z","dateUpdated":"2026-04-08T17:34:09.858Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-19T20:31:02.075Z"},"containers":{"cna":{"title":"Feedpress Generator – External RSS Frontend Customizer <= 1.2.1 - Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Feedpress Generator – External RSS Frontend Customizer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link."}],"affected":[{"vendor":"spartac","product":"Feedpress Generator – External RSS Frontend Customizer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/f9660aee-1069-4197-b166-12ea30f8fd0c?source=cve"},{"url":"https://wordpress.org/plugins/feedpress-generator/#developers"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:34:09.858Z"},"credits":[{"lang":"en","type":"finder","value":"Thien Ngo"}],"timeline":[{"time":"2024-12-06T21:29:02.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-09T17:37:11.612039Z","id":"CVE-2024-11457","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-09T18:02:25.381Z"}}]}}}