{"id":"CVE-2024-11411","state":"PUBLISHED","title":"Spotlightr <= 0.1.11 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Spotlightr plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'spotlightr-v' shortcode in all versions up to, and including, 0.1.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2024-12-20T06:59:05.818Z","updatedAt":"2026-04-08T16:49:59.361Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["socratous139 Spotlightr"],"affected":[{"vendor":"socratous139","product":"Spotlightr","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1.11","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/475f2758-27a5-4a36-8085-576ee341938b?source=cve","https://wordpress.org/plugins/spotlightr/","https://plugins.trac.wordpress.org/browser/spotlightr/trunk/spotlightr.php","https://plugins.trac.wordpress.org/changeset/3231975/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/11xxx/CVE-2024-11411.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11411","state":"PUBLISHED","datePublished":"2024-12-20T06:59:05.818Z","dateUpdated":"2026-04-08T16:49:59.361Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-19T13:53:46.686Z"},"containers":{"cna":{"title":"Spotlightr <= 0.1.11 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Spotlightr plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'spotlightr-v' shortcode in all versions up to, and including, 0.1.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"socratous139","product":"Spotlightr","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1.11","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/475f2758-27a5-4a36-8085-576ee341938b?source=cve"},{"url":"https://wordpress.org/plugins/spotlightr/"},{"url":"https://plugins.trac.wordpress.org/browser/spotlightr/trunk/spotlightr.php"},{"url":"https://plugins.trac.wordpress.org/changeset/3231975/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:49:59.361Z"},"credits":[{"lang":"en","type":"finder","value":"SOPROBRO"}],"timeline":[{"time":"2024-12-19T18:02:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-20T16:06:48.946608Z","id":"CVE-2024-11411","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-20T16:07:03.792Z"}}]}}}