{"id":"CVE-2024-11338","state":"PUBLISHED","title":"PIXNET Plugin <= 2.9.10 - Authenticated (Subscriber+) Stored Cross-Site Scripting","description":"The PIXNET Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'gtm' and 'venue' parameters in all versions up to, and including, 2.9.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-01-07T04:21:56.040Z","updatedAt":"2026-04-08T16:37:08.696Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["daniel1088 PIXNET Plugin"],"affected":[{"vendor":"daniel1088","product":"PIXNET Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.9.10","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/165bafd4-0cef-4936-af21-6a8ffcfccaef?source=cve","https://wordpress.org/plugins/pixnet/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/11xxx/CVE-2024-11338.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11338","state":"PUBLISHED","datePublished":"2025-01-07T04:21:56.040Z","dateUpdated":"2026-04-08T16:37:08.696Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-18T15:44:17.179Z"},"containers":{"cna":{"title":"PIXNET Plugin <= 2.9.10 - Authenticated (Subscriber+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The PIXNET Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'gtm' and 'venue' parameters in all versions up to, and including, 2.9.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"daniel1088","product":"PIXNET Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.9.10","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/165bafd4-0cef-4936-af21-6a8ffcfccaef?source=cve"},{"url":"https://wordpress.org/plugins/pixnet/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:37:08.696Z"},"credits":[{"lang":"en","type":"finder","value":"SOPROBRO"}],"timeline":[{"time":"2025-01-06T16:15:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-07T15:54:45.562083Z","id":"CVE-2024-11338","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-07T16:25:54.421Z"}}]}}}