{"id":"CVE-2024-10979","state":"PUBLISHED","title":"PostgreSQL PL/Perl environment variable changes execute arbitrary code","description":"Incorrect control of environment variables in PostgreSQL PL/Perl allows an unprivileged database user to change sensitive process environment variables (e.g. PATH).  That often suffices to enable arbitrary code execution, even if the attacker lacks a database server operating system user.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.","publishedAt":"2024-11-14T13:00:08.586Z","updatedAt":"2025-11-03T21:51:41.330Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"PostgreSQL"},"assigner":"PostgreSQL","products":["n/a PostgreSQL"],"affected":[{"vendor":"n/a","product":"PostgreSQL","defaultStatus":"unaffected","versions":[{"version":"17","status":"affected","lessThan":"17.1","versionType":"rpm"},{"version":"16","status":"affected","lessThan":"16.5","versionType":"rpm"},{"version":"15","status":"affected","lessThan":"15.9","versionType":"rpm"},{"version":"14","status":"affected","lessThan":"14.14","versionType":"rpm"},{"version":"13","status":"affected","lessThan":"13.17","versionType":"rpm"},{"version":"0","status":"affected","lessThan":"12.21","versionType":"rpm"}]}],"references":["https://www.postgresql.org/support/security/CVE-2024-10979/","https://github.com/fmora50591/postgresql-env-vuln/blob/main/README.md","https://security.netapp.com/advisory/ntap-20250110-0003/","https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html"],"weaknesses":["CWE-15"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/10xxx/CVE-2024-10979.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10979","state":"PUBLISHED","datePublished":"2024-11-14T13:00:08.586Z","dateUpdated":"2025-11-03T21:51:41.330Z","assignerShortName":"PostgreSQL","assignerOrgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateReserved":"2024-11-07T19:27:04.476Z"},"containers":{"cna":{"title":"PostgreSQL PL/Perl environment variable changes execute arbitrary code","descriptions":[{"lang":"en","value":"Incorrect control of environment variables in PostgreSQL PL/Perl allows an unprivileged database user to change sensitive process environment variables (e.g. PATH).  That often suffices to enable arbitrary code execution, even if the attacker lacks a database server operating system user.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected."}],"affected":[{"vendor":"n/a","product":"PostgreSQL","defaultStatus":"unaffected","versions":[{"version":"17","status":"affected","lessThan":"17.1","versionType":"rpm"},{"version":"16","status":"affected","lessThan":"16.5","versionType":"rpm"},{"version":"15","status":"affected","lessThan":"15.9","versionType":"rpm"},{"version":"14","status":"affected","lessThan":"14.14","versionType":"rpm"},{"version":"13","status":"affected","lessThan":"13.17","versionType":"rpm"},{"version":"0","status":"affected","lessThan":"12.21","versionType":"rpm"}]}],"references":[{"url":"https://www.postgresql.org/support/security/CVE-2024-10979/"}],"metrics":[{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-15","lang":"en","type":"CWE","description":"External Control of System or Configuration Setting"}]}],"providerMetadata":{"shortName":"PostgreSQL","orgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateUpdated":"2024-11-14T13:00:08.586Z"},"configurations":[{"lang":"en","value":"administrator has installed PL/Perl"},{"lang":"en","value":"attacker has permission to create objects (temporary objects or non-temporary objects in at least one schema)"}],"credits":[{"lang":"en","value":"The PostgreSQL project thanks Coby Abrams for reporting this problem."}]},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"postgresql","product":"postgresql","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThan":"12.21","versionType":"rpm"},{"version":"13","status":"affected","lessThan":"13.17","versionType":"rpm"},{"version":"14","status":"affected","lessThan":"14.14","versionType":"rpm"},{"version":"15","status":"affected","lessThan":"15.9","versionType":"rpm"},{"version":"16","status":"affected","lessThan":"16.5","versionType":"rpm"},{"version":"17","status":"affected","lessThan":"17.1","versionType":"rpm"}],"cpes":["cpe:2.3:a:postgresql:postgresql:-:*:*:*:*:*:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-11-20T00:00:00+00:00","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3","id":"CVE-2024-10979"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-21T04:55:16.916Z"}},{"title":"CVE Program Container","references":[{"url":"https://github.com/fmora50591/postgresql-env-vuln/blob/main/README.md"},{"url":"https://security.netapp.com/advisory/ntap-20250110-0003/"},{"url":"https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T21:51:41.330Z"}}]}}}