{"id":"CVE-2024-10977","state":"PUBLISHED","title":"PostgreSQL libpq retains an error message from man-in-the-middle","description":"Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application.  For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results.  This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.","publishedAt":"2024-11-14T13:00:05.715Z","updatedAt":"2025-11-03T21:51:38.414Z","severity":{"score":3.1,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"PostgreSQL"},"assigner":"PostgreSQL","products":["n/a PostgreSQL"],"affected":[{"vendor":"n/a","product":"PostgreSQL","defaultStatus":"unaffected","versions":[{"version":"17","status":"affected","lessThan":"17.1","versionType":"rpm"},{"version":"16","status":"affected","lessThan":"16.5","versionType":"rpm"},{"version":"15","status":"affected","lessThan":"15.9","versionType":"rpm"},{"version":"14","status":"affected","lessThan":"14.14","versionType":"rpm"},{"version":"13","status":"affected","lessThan":"13.17","versionType":"rpm"},{"version":"0","status":"affected","lessThan":"12.21","versionType":"rpm"}]}],"references":["https://www.postgresql.org/support/security/CVE-2024-10977/","https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html"],"weaknesses":["CWE-348"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/10xxx/CVE-2024-10977.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10977","state":"PUBLISHED","datePublished":"2024-11-14T13:00:05.715Z","dateUpdated":"2025-11-03T21:51:38.414Z","assignerShortName":"PostgreSQL","assignerOrgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateReserved":"2024-11-07T19:27:03.261Z"},"containers":{"cna":{"title":"PostgreSQL libpq retains an error message from man-in-the-middle","descriptions":[{"lang":"en","value":"Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application.  For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results.  This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected."}],"affected":[{"vendor":"n/a","product":"PostgreSQL","defaultStatus":"unaffected","versions":[{"version":"17","status":"affected","lessThan":"17.1","versionType":"rpm"},{"version":"16","status":"affected","lessThan":"16.5","versionType":"rpm"},{"version":"15","status":"affected","lessThan":"15.9","versionType":"rpm"},{"version":"14","status":"affected","lessThan":"14.14","versionType":"rpm"},{"version":"13","status":"affected","lessThan":"13.17","versionType":"rpm"},{"version":"0","status":"affected","lessThan":"12.21","versionType":"rpm"}]}],"references":[{"url":"https://www.postgresql.org/support/security/CVE-2024-10977/"}],"metrics":[{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":3.1,"baseSeverity":"LOW"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-348","lang":"en","type":"CWE","description":"Use of Less Trusted Source"}]}],"providerMetadata":{"shortName":"PostgreSQL","orgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateUpdated":"2024-11-14T13:00:05.715Z"},"credits":[{"lang":"en","value":"The PostgreSQL project thanks Jacob Champion for reporting this problem."}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-11-14T18:53:39.616679Z","id":"CVE-2024-10977","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-14T19:31:59.396Z"}},{"title":"CVE Program Container","references":[{"url":"https://lists.debian.org/debian-lts-announce/2024/11/msg00011.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T21:51:38.414Z"}}]}}}