{"id":"CVE-2024-10890","state":"PUBLISHED","title":"WPAdverts – Classifieds Plugin <= 2.1.7 - Reflected Cross-Site Scripting","description":"The WPAdverts – Classifieds Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.1.7. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","publishedAt":"2024-11-21T07:35:36.033Z","updatedAt":"2026-04-08T16:54:42.985Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["gwin WPAdverts – Classifieds Plugin"],"affected":[{"vendor":"gwin","product":"WPAdverts – Classifieds Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.7","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/592ee7b9-7016-4df3-9218-6f7aebf80503?source=cve","https://plugins.trac.wordpress.org/browser/wpadverts/tags/2.1.7/includes/shortcodes.php#L545","https://plugins.trac.wordpress.org/changeset/3192192/wpadverts/trunk/includes/shortcodes.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/10xxx/CVE-2024-10890.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10890","state":"PUBLISHED","datePublished":"2024-11-21T07:35:36.033Z","dateUpdated":"2026-04-08T16:54:42.985Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-05T17:08:35.123Z"},"containers":{"cna":{"title":"WPAdverts – Classifieds Plugin <= 2.1.7 - Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WPAdverts – Classifieds Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.1.7. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link."}],"affected":[{"vendor":"gwin","product":"WPAdverts – Classifieds Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.1.7","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/592ee7b9-7016-4df3-9218-6f7aebf80503?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpadverts/tags/2.1.7/includes/shortcodes.php#L545"},{"url":"https://plugins.trac.wordpress.org/changeset/3192192/wpadverts/trunk/includes/shortcodes.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:54:42.985Z"},"credits":[{"lang":"en","type":"finder","value":"Peter Thaleikis"}],"timeline":[{"time":"2024-11-20T19:06:24.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2024-10890","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2024-11-21T11:29:00.772146Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-21T11:30:08.825Z"}}]}}}