{"id":"CVE-2024-10728","state":"PUBLISHED","title":"PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation","description":"The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized plugin installation/activation due to a missing capability check on the 'install_required_plugin_callback' function in all versions up to, and including, 4.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated.","publishedAt":"2024-11-16T04:29:15.146Z","updatedAt":"2026-04-08T16:33:58.119Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["wpxpo Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX"],"affected":[{"vendor":"wpxpo","product":"Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.16","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/076f36fb-c2fb-43e0-a027-1351d3995489?source=cve","https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Importer.php#L94","https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Initialization.php#L330","https://wordpress.org/plugins/ultimate-post/","https://plugins.trac.wordpress.org/changeset/3188636/ultimate-post/trunk/classes/Importer.php"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/10xxx/CVE-2024-10728.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10728","state":"PUBLISHED","datePublished":"2024-11-16T04:29:15.146Z","dateUpdated":"2026-04-08T16:33:58.119Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-11-02T01:38:53.821Z"},"containers":{"cna":{"title":"PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation","descriptions":[{"lang":"en","value":"The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized plugin installation/activation due to a missing capability check on the 'install_required_plugin_callback' function in all versions up to, and including, 4.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated."}],"affected":[{"vendor":"wpxpo","product":"Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.16","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/076f36fb-c2fb-43e0-a027-1351d3995489?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Importer.php#L94"},{"url":"https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Initialization.php#L330"},{"url":"https://wordpress.org/plugins/ultimate-post/"},{"url":"https://plugins.trac.wordpress.org/changeset/3188636/ultimate-post/trunk/classes/Importer.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:33:58.119Z"},"credits":[{"lang":"en","type":"finder","value":"Sean Murphy"}],"timeline":[{"time":"2024-11-15T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","affected":[{"vendor":"wpxpo","product":"postx_-_gutenberg_blocks_for_post_grid","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.1.16","versionType":"semver"}],"cpes":["cpe:2.3:a:wpxpo:postx_-_gutenberg_blocks_for_post_grid:*:*:*:*:*:wordpress:*:*"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-11-18T15:41:57.460591Z","id":"CVE-2024-10728","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-11-19T16:06:27.550Z"}}]}}}