{"id":"CVE-2024-10040","state":"PUBLISHED","title":"Infinite-Scroll <= 2.6.2 - Cross-Site Request Forgery to Plugin Settings Update","description":"The Infinite-Scroll plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.2. This is due to missing or incorrect nonce validation on the process_ajax_edit and process_ajax_delete function. This makes it possible for unauthenticated attackers to make changes to plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2024-10-18T04:32:52.212Z","updatedAt":"2026-04-08T16:48:21.747Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["paulirish-1 Infinite-Scroll"],"affected":[{"vendor":"paulirish-1","product":"Infinite-Scroll","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.6.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/4045575a-35f0-46e5-afb7-93eee9be3a97?source=cve","https://plugins.trac.wordpress.org/browser/infinite-scroll/trunk/includes/presets.php#L252","https://plugins.trac.wordpress.org/browser/infinite-scroll/trunk/includes/presets.php#L275"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:06:50.777Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2024/10xxx/CVE-2024-10040.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10040","state":"PUBLISHED","datePublished":"2024-10-18T04:32:52.212Z","dateUpdated":"2026-04-08T16:48:21.747Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2024-10-16T15:56:31.121Z"},"containers":{"cna":{"title":"Infinite-Scroll <= 2.6.2 - Cross-Site Request Forgery to Plugin Settings Update","descriptions":[{"lang":"en","value":"The Infinite-Scroll plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.2. This is due to missing or incorrect nonce validation on the process_ajax_edit and process_ajax_delete function. This makes it possible for unauthenticated attackers to make changes to plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"paulirish-1","product":"Infinite-Scroll","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.6.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/4045575a-35f0-46e5-afb7-93eee9be3a97?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/infinite-scroll/trunk/includes/presets.php#L252"},{"url":"https://plugins.trac.wordpress.org/browser/infinite-scroll/trunk/includes/presets.php#L275"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:48:21.747Z"},"credits":[{"lang":"en","type":"finder","value":"Francesco Carlucci"}],"timeline":[{"time":"2024-10-17T15:41:50.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-18T17:12:57.455625Z","id":"CVE-2024-10040","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-18T17:19:54.761Z"}}]}}}