{"id":"CVE-2023-6148","state":"PUBLISHED","title":"Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance","description":"Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data","publishedAt":"2024-01-09T08:14:51.063Z","updatedAt":"2025-04-17T17:59:33.171Z","severity":{"score":5.7,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","source":"Qualys"},"assigner":"Qualys","products":["Qualys,Inc. Policy Compliance Connector Jenkins Plugin"],"affected":[{"vendor":"Qualys,Inc.","product":"Policy Compliance Connector Jenkins Plugin","defaultStatus":"unaffected","versions":[{"version":"1.0.5","status":"affected","lessThanOrEqual":"1.0.2","changes":[{"at":"1.0.6","status":"unaffected"}],"versionType":"custom"}]}],"references":["https://www.qualys.com/security-advisories/","http://www.openwall.com/lists/oss-security/2024/01/24/6"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:42.242Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/6xxx/CVE-2023-6148.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-6148","state":"PUBLISHED","datePublished":"2024-01-09T08:14:51.063Z","dateUpdated":"2025-04-17T17:59:33.171Z","assignerShortName":"Qualys","assignerOrgId":"8a309ac4-d8c7-4735-9c1d-ca39c5dfbcda","dateReserved":"2023-11-15T10:10:26.359Z"},"containers":{"cna":{"title":"Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance","descriptions":[{"lang":"en","value":"Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data"}],"affected":[{"vendor":"Qualys,Inc.","product":"Policy Compliance Connector Jenkins Plugin","defaultStatus":"unaffected","versions":[{"version":"1.0.5","status":"affected","lessThanOrEqual":"1.0.2","changes":[{"at":"1.0.6","status":"unaffected"}],"versionType":"custom"}]}],"references":[{"url":"https://www.qualys.com/security-advisories/"},{"url":"http://www.openwall.com/lists/oss-security/2024/01/24/6"}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.7,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Qualys","orgId":"8a309ac4-d8c7-4735-9c1d-ca39c5dfbcda","dateUpdated":"2024-01-24T18:06:27.107Z"},"credits":[{"lang":"en","type":"reporter","user":"00000000-0000-4000-9000-000000000000","value":"Yaroslav Afenkin, CloudBees, Inc."}],"datePublic":"2024-01-09T08:09:00.000Z","solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"<span style=\"background-color: rgb(255, 255, 255);\">Customers should upgrade to a minimum version of 1.0.6.</span><span style=\"background-color: rgb(255, 255, 255);\">&nbsp;</span>\n\n<br>"}],"value":"Customers should upgrade to a minimum version of 1.0.6."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.qualys.com/security-advisories/","tags":["x_transferred"]},{"url":"http://www.openwall.com/lists/oss-security/2024/01/24/6","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T08:21:17.559Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-01-10T18:23:49.043487Z","id":"CVE-2023-6148","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-17T17:59:33.171Z"}}]}}}