{"id":"CVE-2023-5816","state":"PUBLISHED","title":"Code Explorer <= 1.4.5 - Authenticated (Admin+) External File Reading","description":"The Code Explorer plugin for WordPress is vulnerable to arbitrary external file reading in all versions up to, and including, 1.4.5. This is due to the fact that the plugin does not restrict accessing files to those outside of the WordPress instance, though the intention of the plugin is to only access WordPress related files. This makes it possible for authenticated attackers, with administrator-level access, to read files outside of the WordPress instance.","publishedAt":"2024-10-30T02:04:35.541Z","updatedAt":"2026-04-08T16:49:01.126Z","severity":{"score":4.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["qriouslad Code Explorer"],"affected":[{"vendor":"qriouslad","product":"Code Explorer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/42ecc4e5-d660-472f-823d-a29b84cdf041?source=cve","https://wordpress.org/plugins/code-explorer/#developers","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3234408%40code-explorer&new=3234408%40code-explorer&sfp_email=&sfph_mail="],"weaknesses":["CWE-73"],"ingestedAt":"2026-10-29T20:06:42.242Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/5xxx/CVE-2023-5816.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2023-5816","state":"PUBLISHED","datePublished":"2024-10-30T02:04:35.541Z","dateUpdated":"2026-04-08T16:49:01.126Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2023-10-26T22:28:52.027Z"},"containers":{"cna":{"title":"Code Explorer <= 1.4.5 - Authenticated (Admin+) External File Reading","descriptions":[{"lang":"en","value":"The Code Explorer plugin for WordPress is vulnerable to arbitrary external file reading in all versions up to, and including, 1.4.5. This is due to the fact that the plugin does not restrict accessing files to those outside of the WordPress instance, though the intention of the plugin is to only access WordPress related files. This makes it possible for authenticated attackers, with administrator-level access, to read files outside of the WordPress instance."}],"affected":[{"vendor":"qriouslad","product":"Code Explorer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/42ecc4e5-d660-472f-823d-a29b84cdf041?source=cve"},{"url":"https://wordpress.org/plugins/code-explorer/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3234408%40code-explorer&new=3234408%40code-explorer&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","baseScore":4.9,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-73","lang":"en","description":"CWE-73 External Control of File Name or Path","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:49:01.126Z"},"credits":[{"lang":"en","type":"finder","value":"Dmitrii Ignatyev"}],"timeline":[{"time":"2024-10-29T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-10-30T13:42:18.586533Z","id":"CVE-2023-5816","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-10-30T14:59:31.112Z"}}]}}}