{"id":"CVE-2023-5126","state":"PUBLISHED","title":"Delete Me <= 3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","description":"The Delete Me plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'plugin_delete_me' shortcode in versions up to, and including, 3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The shortcode is not displayed to administrators, so it cannot be used against administrator users.","publishedAt":"2023-10-24T13:53:00.181Z","updatedAt":"2026-04-08T17:02:20.367Z","severity":{"score":4.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["cmc3215 Delete Me"],"affected":[{"vendor":"cmc3215","product":"Delete Me","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/7a5123a7-8eb4-481e-88fe-6310be37a077?source=cve","https://plugins.trac.wordpress.org/browser/delete-me/tags/3.0/inc/shortcode.php#L83","https://plugins.trac.wordpress.org/changeset/2994298/delete-me#file2"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:42.242Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/5xxx/CVE-2023-5126.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2023-5126","state":"PUBLISHED","datePublished":"2023-10-24T13:53:00.181Z","dateUpdated":"2026-04-08T17:02:20.367Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2023-09-22T15:43:01.078Z"},"containers":{"cna":{"title":"Delete Me <= 3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","descriptions":[{"lang":"en","value":"The Delete Me plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'plugin_delete_me' shortcode in versions up to, and including, 3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The shortcode is not displayed to administrators, so it cannot be used against administrator users."}],"affected":[{"vendor":"cmc3215","product":"Delete Me","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7a5123a7-8eb4-481e-88fe-6310be37a077?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/delete-me/tags/3.0/inc/shortcode.php#L83"},{"url":"https://plugins.trac.wordpress.org/changeset/2994298/delete-me#file2"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":4.9,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:02:20.367Z"},"credits":[{"lang":"en","type":"finder","value":"István Márton"}],"timeline":[{"time":"2023-09-21T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2023-09-21T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2023-10-23T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7a5123a7-8eb4-481e-88fe-6310be37a077?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/delete-me/tags/3.0/inc/shortcode.php#L83","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T07:44:53.747Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-05T18:21:39.338976Z","id":"CVE-2023-5126","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-05T18:58:30.410Z"}}]}}}