{"id":"CVE-2023-50254","state":"PUBLISHED","title":"Deepin Reader RCE vulnerability due to a design flaw","description":"Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.","publishedAt":"2023-12-22T16:49:48.977Z","updatedAt":"2024-08-02T22:16:46.096Z","severity":{"score":9.3,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["linuxdeepin developer-center"],"affected":[{"vendor":"linuxdeepin","product":"developer-center","versions":[{"version":"< 6.0.7","status":"affected"}]}],"references":["https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495","https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04","https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6"],"weaknesses":["CWE-27","CWE-22"],"ingestedAt":"2026-10-29T20:06:33.064Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/50xxx/CVE-2023-50254.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-50254","state":"PUBLISHED","datePublished":"2023-12-22T16:49:48.977Z","dateUpdated":"2024-08-02T22:16:46.096Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2023-12-05T20:42:59.378Z"},"containers":{"cna":{"title":"Deepin Reader RCE vulnerability due to a design flaw","descriptions":[{"lang":"en","value":"Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue."}],"affected":[{"vendor":"linuxdeepin","product":"developer-center","versions":[{"version":"< 6.0.7","status":"affected"}]}],"references":[{"url":"https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495","name":"https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04","name":"https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04","tags":["x_refsource_MISC"]},{"url":"https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6","name":"https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.3,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-27","lang":"en","description":"CWE-27: Path Traversal: 'dir/../../filename'","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-22","lang":"en","description":"CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2023-12-22T16:49:48.977Z"},"source":{"advisory":"GHSA-q9jr-726g-9495","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495","name":"https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04","name":"https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6","name":"https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T22:16:46.096Z"}}]}}}