{"id":"CVE-2023-49086","state":"PUBLISHED","title":"Cacti is vulnerable to cross-Site scripting (XSS) DOM","description":"Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.","publishedAt":"2023-12-21T23:29:45.134Z","updatedAt":"2025-11-04T18:19:36.814Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["Cacti cacti"],"affected":[{"vendor":"Cacti","product":"cacti","versions":[{"version":"< 1.2.27","status":"affected"}]}],"references":["https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr","https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/","https://lists.debian.org/debian-lts-announce/2024/03/msg00018.html"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:24.729Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/49xxx/CVE-2023-49086.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2023-49086","state":"PUBLISHED","datePublished":"2023-12-21T23:29:45.134Z","dateUpdated":"2025-11-04T18:19:36.814Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2023-11-21T18:57:30.428Z"},"containers":{"cna":{"title":"Cacti is vulnerable to cross-Site scripting (XSS) DOM","descriptions":[{"lang":"en","value":"Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27."}],"affected":[{"vendor":"Cacti","product":"cacti","versions":[{"version":"< 1.2.27","status":"affected"}]}],"references":[{"url":"https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr","name":"https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9","name":"https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9","tags":["x_refsource_MISC"]},{"url":"https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/"}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2024-06-10T16:09:39.269Z"},"source":{"advisory":"GHSA-wc73-r2vw-59pr","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr","name":"https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9","name":"https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/","tags":["x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2024/03/msg00018.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-04T18:19:36.814Z"}}]}}}