{"id":"CVE-2023-39314","state":"PUBLISHED","title":"WordPress Leyka Plugin <= 3.30.2 is vulnerable to Cross Site Scripting (XSS)","description":"Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.30.2 versions.","publishedAt":"2023-08-10T12:46:48.926Z","updatedAt":"2026-04-28T16:08:34.725Z","severity":{"score":7.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["Teplitsa of social technologies Leyka"],"affected":[{"vendor":"Teplitsa of social technologies","product":"Leyka","packageName":"leyka","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"3.30.2","changes":[{"at":"3.30.3","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/vulnerability/leyka/wordpress-leyka-plugin-3-30-2-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:08.715Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/39xxx/CVE-2023-39314.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2023-39314","state":"PUBLISHED","datePublished":"2023-08-10T12:46:48.926Z","dateUpdated":"2026-04-28T16:08:34.725Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2023-07-27T14:35:24.631Z"},"containers":{"cna":{"title":"WordPress Leyka Plugin <= 3.30.2 is vulnerable to Cross Site Scripting (XSS)","descriptions":[{"lang":"en","value":"Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Teplitsa of social technologies Leyka plugin <= 3.30.2 versions."}],"affected":[{"vendor":"Teplitsa of social technologies","product":"Leyka","packageName":"leyka","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"3.30.2","changes":[{"at":"3.30.3","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/vulnerability/leyka/wordpress-leyka-plugin-3-30-2-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.1,"baseSeverity":"HIGH","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:08:34.725Z"},"credits":[{"lang":"en","type":"finder","user":"00000000-0000-4000-9000-000000000000","value":"Phd (Patchstack Alliance)"}],"impacts":[{"capecId":"CAPEC-591","descriptions":[{"lang":"en","value":"CAPEC-591 Reflected XSS"}]}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Update to 3.30.3 or a higher version.<br><br>Attention! The vendor applied the patch without bumping up the version number (version 3.30.3 might be vulnerable if downloaded before 07/31/2023 01:24:13 PM).<br>"}],"value":"Update to 3.30.3 or a higher version.\n\nAttention! The vendor applied the patch without bumping up the version number (version 3.30.3 might be vulnerable if downloaded before 07/31/2023 01:24:13 PM)."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/database/vulnerability/leyka/wordpress-leyka-plugin-3-30-2-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T18:02:06.939Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-09-25T14:32:15.634338Z","id":"CVE-2023-39314","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-09-25T15:03:30.272Z"}}]}}}