{"id":"CVE-2023-38000","state":"PUBLISHED","title":"Auth. Stored Cross-Site Scripting (XSS) vulnerability in WordPress core and Gutenberg plugin via Navigation Links Block","description":"Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin <= 16.8.0 versions.","publishedAt":"2023-10-13T09:55:54.690Z","updatedAt":"2026-04-28T16:08:33.786Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["WordPress.org WordPress","Gutenberg Team Gutenberg"],"affected":[{"vendor":"WordPress.org","product":"WordPress","defaultStatus":"unaffected","versions":[{"version":"6.3","status":"affected","lessThanOrEqual":"6.3.1","changes":[{"at":"6.3.2","status":"unaffected"}],"versionType":"custom"},{"version":"6.2","status":"affected","lessThanOrEqual":"6.2.2","changes":[{"at":"6.2.3","status":"unaffected"}],"versionType":"custom"},{"version":"6.1","status":"affected","lessThanOrEqual":"6.1.3","changes":[{"at":"6.1.4","status":"unaffected"}],"versionType":"custom"},{"version":"6.0","status":"affected","lessThanOrEqual":"6.0.5","changes":[{"at":"6.0.6","status":"unaffected"}],"versionType":"custom"},{"version":"5.9","status":"affected","lessThanOrEqual":"5.9.7","changes":[{"at":"5.9.8","status":"unaffected"}],"versionType":"custom"}]},{"vendor":"Gutenberg Team","product":"Gutenberg","packageName":"gutenberg","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"16.8.0","changes":[{"at":"16.8.1","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/articles/wordpress-core-6-3-2-security-update-technical-advisory?_s_id=cve","https://patchstack.com/database/vulnerability/wordpress/wordpress-core-6-3-2-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve","https://patchstack.com/database/vulnerability/gutenberg/wordpress-gutenberg-plugin-16-8-0-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:06:08.715Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/38xxx/CVE-2023-38000.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2023-38000","state":"PUBLISHED","datePublished":"2023-10-13T09:55:54.690Z","dateUpdated":"2026-04-28T16:08:33.786Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2023-07-11T12:50:13.630Z"},"containers":{"cna":{"title":"Auth. Stored Cross-Site Scripting (XSS) vulnerability in WordPress core and Gutenberg plugin via Navigation Links Block","descriptions":[{"lang":"en","value":"Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin <= 16.8.0 versions."}],"affected":[{"vendor":"WordPress.org","product":"WordPress","defaultStatus":"unaffected","versions":[{"version":"6.3","status":"affected","lessThanOrEqual":"6.3.1","changes":[{"at":"6.3.2","status":"unaffected"}],"versionType":"custom"},{"version":"6.2","status":"affected","lessThanOrEqual":"6.2.2","changes":[{"at":"6.2.3","status":"unaffected"}],"versionType":"custom"},{"version":"6.1","status":"affected","lessThanOrEqual":"6.1.3","changes":[{"at":"6.1.4","status":"unaffected"}],"versionType":"custom"},{"version":"6.0","status":"affected","lessThanOrEqual":"6.0.5","changes":[{"at":"6.0.6","status":"unaffected"}],"versionType":"custom"},{"version":"5.9","status":"affected","lessThanOrEqual":"5.9.7","changes":[{"at":"5.9.8","status":"unaffected"}],"versionType":"custom"}]},{"vendor":"Gutenberg Team","product":"Gutenberg","packageName":"gutenberg","defaultStatus":"unaffected","versions":[{"version":"n/a","status":"affected","lessThanOrEqual":"16.8.0","changes":[{"at":"16.8.1","status":"unaffected"}],"versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/articles/wordpress-core-6-3-2-security-update-technical-advisory?_s_id=cve","tags":["third-party-advisory"]},{"url":"https://patchstack.com/database/vulnerability/wordpress/wordpress-core-6-3-2-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve","tags":["vdb-entry"]},{"url":"https://patchstack.com/database/vulnerability/gutenberg/wordpress-gutenberg-plugin-16-8-0-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:08:33.786Z"},"credits":[{"lang":"en","type":"finder","user":"00000000-0000-4000-9000-000000000000","value":"Rafie Muhammad (Patchstack)"},{"lang":"en","type":"finder","user":"00000000-0000-4000-9000-000000000000","value":"Edouard Lamoine (Patchstack)"}],"datePublic":"2023-10-13T05:00:00.000Z","impacts":[{"capecId":"CAPEC-592","descriptions":[{"lang":"en","value":"CAPEC-592 Stored XSS"}]}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Update WordPress core to the 6.3.2, 6.2.3, 6.1.4, 6.0.6, 5.9.8 or a higher version."}],"value":"Update WordPress core to the 6.3.2, 6.2.3, 6.1.4, 6.0.6, 5.9.8 or a higher version."},{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Update Gutenberg to 16.8.1 or a higher version."}],"value":"Update Gutenberg to 16.8.1 or a higher version."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/articles/wordpress-core-6-3-2-security-update-technical-advisory?_s_id=cve","tags":["third-party-advisory","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/wordpress/wordpress-core-6-3-2-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/gutenberg/wordpress-gutenberg-plugin-16-8-0-contributor-stored-xss-in-navigation-links-block-vulnerability?_s_id=cve","tags":["vdb-entry","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T17:23:27.829Z"}}]}}}