{"id":"CVE-2023-29006","state":"PUBLISHED","title":"Order GLPI plugin vulnerable to remote code execution from authenticated user","description":"The Order GLPI plugin allows users to manage order management within GLPI. Starting with version 1.8.0 and prior to versions 2.7.7 and 2.10.1, an authenticated user that has access to standard interface can craft an URL that can be used to execute a system command. Versions 2.7.7 and 2.10.1 contain a patch for this issue. As a workaround, delete the `ajax/dropdownContact.php` file from the plugin.","publishedAt":"2023-04-05T17:53:03.041Z","updatedAt":"2025-02-10T15:23:39.714Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["pluginsGLPI order"],"affected":[{"vendor":"pluginsGLPI","product":"order","versions":[{"version":">= 1.8.0, < 2.7.7","status":"affected"},{"version":">= 2.10.0, < 2.10.1","status":"affected"}]}],"references":["https://github.com/pluginsGLPI/order/security/advisories/GHSA-xfx2-qx2r-3wwm","https://github.com/pluginsGLPI/order/commit/c78e64b95e54d5e47d9835984c93049f245b579e"],"weaknesses":["CWE-502"],"ingestedAt":"2026-10-29T20:05:52.290Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/29xxx/CVE-2023-29006.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-29006","state":"PUBLISHED","datePublished":"2023-04-05T17:53:03.041Z","dateUpdated":"2025-02-10T15:23:39.714Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2023-03-29T17:39:16.142Z"},"containers":{"cna":{"title":"Order GLPI plugin vulnerable to remote code execution from authenticated user","descriptions":[{"lang":"en","value":"The Order GLPI plugin allows users to manage order management within GLPI. Starting with version 1.8.0 and prior to versions 2.7.7 and 2.10.1, an authenticated user that has access to standard interface can craft an URL that can be used to execute a system command. Versions 2.7.7 and 2.10.1 contain a patch for this issue. As a workaround, delete the `ajax/dropdownContact.php` file from the plugin."}],"affected":[{"vendor":"pluginsGLPI","product":"order","versions":[{"version":">= 1.8.0, < 2.7.7","status":"affected"},{"version":">= 2.10.0, < 2.10.1","status":"affected"}]}],"references":[{"url":"https://github.com/pluginsGLPI/order/security/advisories/GHSA-xfx2-qx2r-3wwm","name":"https://github.com/pluginsGLPI/order/security/advisories/GHSA-xfx2-qx2r-3wwm","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/pluginsGLPI/order/commit/c78e64b95e54d5e47d9835984c93049f245b579e","name":"https://github.com/pluginsGLPI/order/commit/c78e64b95e54d5e47d9835984c93049f245b579e","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-502","lang":"en","description":"CWE-502: Deserialization of Untrusted Data","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2023-04-05T17:53:03.041Z"},"source":{"advisory":"GHSA-xfx2-qx2r-3wwm","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/pluginsGLPI/order/security/advisories/GHSA-xfx2-qx2r-3wwm","name":"https://github.com/pluginsGLPI/order/security/advisories/GHSA-xfx2-qx2r-3wwm","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/pluginsGLPI/order/commit/c78e64b95e54d5e47d9835984c93049f245b579e","name":"https://github.com/pluginsGLPI/order/commit/c78e64b95e54d5e47d9835984c93049f245b579e","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T14:00:14.398Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-10T15:23:31.220646Z","id":"CVE-2023-29006","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-10T15:23:39.714Z"}}]}}}