{"id":"CVE-2023-28121","state":"PUBLISHED","title":"An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrat","description":"An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.","publishedAt":"2023-04-12T00:00:00.000Z","updatedAt":"2024-08-02T12:30:24.170Z","severity":null,"assigner":"hackerone","products":["n/a WooCommerce Payments WordPress Plugin"],"affected":[{"vendor":"n/a","product":"WooCommerce Payments WordPress Plugin","versions":[{"version":"Fixed version 5.6.2","status":"affected"}]}],"references":["https://developer.woocommerce.com/2023/03/23/critical-vulnerability-detected-in-woocommerce-payments-what-you-need-to-know/","https://www.rcesecurity.com/2023/07/patch-diffing-cve-2023-28121-to-compromise-a-woocommerce/"],"weaknesses":["CWE-287"],"ingestedAt":"2026-10-29T20:05:52.290Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/28xxx/CVE-2023-28121.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-28121","state":"PUBLISHED","datePublished":"2023-04-12T00:00:00.000Z","dateUpdated":"2024-08-02T12:30:24.170Z","assignerShortName":"hackerone","assignerOrgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateReserved":"2023-03-10T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated."}],"affected":[{"vendor":"n/a","product":"WooCommerce Payments WordPress Plugin","versions":[{"version":"Fixed version 5.6.2","status":"affected"}]}],"references":[{"url":"https://developer.woocommerce.com/2023/03/23/critical-vulnerability-detected-in-woocommerce-payments-what-you-need-to-know/"},{"url":"https://www.rcesecurity.com/2023/07/patch-diffing-cve-2023-28121-to-compromise-a-woocommerce/"}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","type":"CWE","lang":"en","description":"Improper Authentication - Generic (CWE-287)"}]}],"providerMetadata":{"shortName":"hackerone","orgId":"36234546-b8fa-4601-9d6f-f4e334aa8ea1","dateUpdated":"2023-07-03T00:00:00.000Z"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://developer.woocommerce.com/2023/03/23/critical-vulnerability-detected-in-woocommerce-payments-what-you-need-to-know/","tags":["x_transferred"]},{"url":"https://www.rcesecurity.com/2023/07/patch-diffing-cve-2023-28121-to-compromise-a-woocommerce/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T12:30:24.170Z"}}]}}}