{"id":"CVE-2023-27898","state":"PUBLISHED","title":"Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message ","description":"Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.","publishedAt":"2023-03-08T17:14:48.437Z","updatedAt":"2025-02-28T18:34:50.742Z","severity":{"score":9.6,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","source":"CISA-ADP"},"assigner":"jenkins","products":["Jenkins Project Jenkins"],"affected":[{"vendor":"Jenkins Project","product":"Jenkins","defaultStatus":"unaffected","versions":[{"version":"2.270","status":"affected","lessThan":"2.*","changes":[{"at":"2.375.4","status":"unaffected"},{"at":"2.376","status":"affected"},{"at":"2.387.1","status":"unaffected"},{"at":"2.388","status":"affected"},{"at":"2.394","status":"unaffected"}],"versionType":"maven"}]}],"references":["https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3037"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:05:52.290Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/27xxx/CVE-2023-27898.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-27898","state":"PUBLISHED","datePublished":"2023-03-08T17:14:48.437Z","dateUpdated":"2025-02-28T18:34:50.742Z","assignerShortName":"jenkins","assignerOrgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateReserved":"2023-03-07T09:35:48.506Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances."}],"affected":[{"vendor":"Jenkins Project","product":"Jenkins","defaultStatus":"unaffected","versions":[{"version":"2.270","status":"affected","lessThan":"2.*","changes":[{"at":"2.375.4","status":"unaffected"},{"at":"2.376","status":"affected"},{"at":"2.387.1","status":"unaffected"},{"at":"2.388","status":"affected"},{"at":"2.394","status":"unaffected"}],"versionType":"maven"}]}],"references":[{"url":"https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3037","name":"Jenkins Security Advisory 2023-03-08","tags":["vendor-advisory"]}],"providerMetadata":{"shortName":"jenkins","orgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateUpdated":"2023-10-24T12:49:02.967Z"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3037","name":"Jenkins Security Advisory 2023-03-08","tags":["vendor-advisory","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T12:23:30.482Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"CHANGED","version":"3.1","baseScore":9.6,"attackVector":"NETWORK","baseSeverity":"CRITICAL","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","integrityImpact":"HIGH","userInteraction":"REQUIRED","attackComplexity":"LOW","availabilityImpact":"HIGH","privilegesRequired":"NONE","confidentialityImpact":"HIGH"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-02-28T18:33:39.047301Z","id":"CVE-2023-27898","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","type":"CWE","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-28T18:34:50.742Z"}}]}}}