{"id":"CVE-2023-2549","state":"PUBLISHED","title":"The Feather Login Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions starting from 1.0.7 up to, and including, 1.1.1. This is due to missing nonce va","description":"The Feather Login Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions starting from 1.0.7 up to, and including, 1.1.1. This is due to missing nonce validation in the 'createTempAccountLink' function. This makes it possible for unauthenticated attackers to create a new user with administrator role via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. An attacker can leverage CVE-2023-2545 to get the login link or request a password reset to the new user's email address.","publishedAt":"2023-05-31T02:40:19.517Z","updatedAt":"2025-01-13T16:32:05.929Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["featherplugins Custom Login Page | Temporary Users | Rebrand Login | Login Captcha"],"affected":[{"vendor":"featherplugins","product":"Custom Login Page | Temporary Users | Rebrand Login | Login Captcha","defaultStatus":"unaffected","versions":[{"version":"1.0.7","status":"affected","lessThanOrEqual":"1.1.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/12560b8e-9c47-4f7f-ac9c-d86f17914ba3?source=cve","https://plugins.trac.wordpress.org/browser/feather-login-page/trunk/features/inc/admin/expirable-login-link.php?rev=2612332#L206"],"weaknesses":[],"ingestedAt":"2026-10-29T20:05:52.290Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/2xxx/CVE-2023-2549.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-2549","state":"PUBLISHED","datePublished":"2023-05-31T02:40:19.517Z","dateUpdated":"2025-01-13T16:32:05.929Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2023-05-05T17:13:28.059Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"The Feather Login Page plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions starting from 1.0.7 up to, and including, 1.1.1. This is due to missing nonce validation in the 'createTempAccountLink' function. This makes it possible for unauthenticated attackers to create a new user with administrator role via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. An attacker can leverage CVE-2023-2545 to get the login link or request a password reset to the new user's email address."}],"affected":[{"vendor":"featherplugins","product":"Custom Login Page | Temporary Users | Rebrand Login | Login Captcha","defaultStatus":"unaffected","versions":[{"version":"1.0.7","status":"affected","lessThanOrEqual":"1.1.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/12560b8e-9c47-4f7f-ac9c-d86f17914ba3?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/feather-login-page/trunk/features/inc/admin/expirable-login-link.php?rev=2612332#L206"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2023-05-31T02:40:19.517Z"},"credits":[{"lang":"en","type":"finder","value":"Lana Codes"}],"timeline":[{"time":"2023-05-04T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2023-05-04T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2023-05-30T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/12560b8e-9c47-4f7f-ac9c-d86f17914ba3?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/feather-login-page/trunk/features/inc/admin/expirable-login-link.php?rev=2612332#L206","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T06:26:09.582Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-13T16:19:22.127506Z","id":"CVE-2023-2549","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-13T16:32:05.929Z"}}]}}}