{"id":"CVE-2023-22468","state":"PUBLISHED","title":"Discourse vulnerable to Cross-site Scripting in local oneboxes","description":"Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site  scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.","publishedAt":"2023-01-26T08:31:00.485Z","updatedAt":"2025-03-10T21:19:31.635Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["discourse discourse"],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"stable < 2.8.14","status":"affected"},{"version":"beta < 3.0.0.beta16","status":"affected"},{"version":"tests-passed < 3.0.0.beta16","status":"affected"}]}],"references":["https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:05:43.909Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2023/22xxx/CVE-2023-22468.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2023-22468","state":"PUBLISHED","datePublished":"2023-01-26T08:31:00.485Z","dateUpdated":"2025-03-10T21:19:31.635Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-12-29T03:00:40.880Z"},"containers":{"cna":{"title":"Discourse vulnerable to Cross-site Scripting in local oneboxes","descriptions":[{"lang":"en","value":"Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site  scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse."}],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"stable < 2.8.14","status":"affected"},{"version":"beta < 3.0.0.beta16","status":"affected"},{"version":"tests-passed < 3.0.0.beta16","status":"affected"}]}],"references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m","name":"https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2023-01-26T08:31:00.485Z"},"source":{"advisory":"GHSA-8mr2-xf8r-wr8m","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m","name":"https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T10:13:48.412Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-10T20:58:26.865632Z","id":"CVE-2023-22468","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-10T21:19:31.635Z"}}]}}}