{"id":"CVE-2022-4519","state":"PUBLISHED","title":"WP User <= 7.0 - Authenticated (Administrator+) Stored Cross-Site Scripting","description":"The WP User plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its settings parameters in versions up to, and including, 7.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.","publishedAt":"2022-12-15T19:19:18.205Z","updatedAt":"2026-04-08T17:06:28.985Z","severity":{"score":5.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["walkeprashant WP User – Custom Registration Forms, Login and User Profile"],"affected":[{"vendor":"walkeprashant","product":"WP User – Custom Registration Forms, Login and User Profile","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/8ee21796-5340-4f84-b1c4-a95137a27223?source=cve","https://wordpress.org/plugins/wp-user/#description","https://www.wordfence.com/threat-intel/vulnerabilities/id/8ee21796-5340-4f84-b1c4-a95137a27223"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:05:26.763Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/4xxx/CVE-2022-4519.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-4519","state":"PUBLISHED","datePublished":"2022-12-15T19:19:18.205Z","dateUpdated":"2026-04-08T17:06:28.985Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","requesterUserId":"8d345d3f-a59e-4410-a440-fac6e918fcfc","dateReserved":"2022-12-15T19:19:02.372Z"},"containers":{"cna":{"title":"WP User <= 7.0 - Authenticated (Administrator+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP User plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its settings parameters in versions up to, and including, 7.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"affected":[{"vendor":"walkeprashant","product":"WP User – Custom Registration Forms, Login and User Profile","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/8ee21796-5340-4f84-b1c4-a95137a27223?source=cve"},{"url":"https://wordpress.org/plugins/wp-user/#description"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":5.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:06:28.985Z"},"credits":[{"lang":"en","type":"finder","value":"Marco Wotschka"}],"timeline":[{"time":"2022-12-06T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/8ee21796-5340-4f84-b1c4-a95137a27223","tags":["x_transferred"]},{"url":"https://wordpress.org/plugins/wp-user/#description","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T01:41:45.618Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-23T20:26:25.796259Z","id":"CVE-2022-4519","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-23T20:26:31.537Z"}}]}}}