{"id":"CVE-2022-4169","state":"PUBLISHED","title":"Theme and plugin translation for Polylang <= 3.2.16 - Missing Authorization","description":"The Theme and plugin translation for Polylang is vulnerable to authorization bypass in versions up to, and including, 3.2.16 due to missing capability checks in the process_polylang_theme_translation_wp_loaded() function. This makes it possible for unauthenticated attackers to update plugin and theme translation settings and to import translation strings.","publishedAt":"2022-11-28T17:33:31.980Z","updatedAt":"2026-04-08T17:11:57.962Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","source":"Wordfence"},"assigner":"Wordfence","products":["marcinkazmierski Theme and plugin translation for Polylang (TTfP)"],"affected":[{"vendor":"marcinkazmierski","product":"Theme and plugin translation for Polylang (TTfP)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.2.16","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/9f6a358a-333c-4eb7-9149-348bf3713943?source=cve","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2814605%40theme-translation-for-polylang%2Ftrunk&old=2812254%40theme-translation-for-polylang%2Ftrunk&sfp_email=&sfph_mail=","https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4169"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T20:05:26.763Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/4xxx/CVE-2022-4169.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-4169","state":"PUBLISHED","datePublished":"2022-11-28T17:33:31.980Z","dateUpdated":"2026-04-08T17:11:57.962Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","requesterUserId":"8d345d3f-a59e-4410-a440-fac6e918fcfc","dateReserved":"2022-11-28T17:28:03.180Z"},"containers":{"cna":{"title":"Theme and plugin translation for Polylang <= 3.2.16 - Missing Authorization","descriptions":[{"lang":"en","value":"The Theme and plugin translation for Polylang is vulnerable to authorization bypass in versions up to, and including, 3.2.16 due to missing capability checks in the process_polylang_theme_translation_wp_loaded() function. This makes it possible for unauthenticated attackers to update plugin and theme translation settings and to import translation strings."}],"affected":[{"vendor":"marcinkazmierski","product":"Theme and plugin translation for Polylang (TTfP)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.2.16","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/9f6a358a-333c-4eb7-9149-348bf3713943?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2814605%40theme-translation-for-polylang%2Ftrunk&old=2812254%40theme-translation-for-polylang%2Ftrunk&sfp_email=&sfph_mail="},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4169"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:11:57.962Z"},"credits":[{"lang":"en","type":"finder","value":"Florent BESNARD"}],"timeline":[{"time":"2022-11-28T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2814605%40theme-translation-for-polylang%2Ftrunk&old=2812254%40theme-translation-for-polylang%2Ftrunk&sfp_email=&sfph_mail=","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4169","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T01:34:49.301Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-07T20:31:55.763067Z","id":"CVE-2022-4169","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-07T20:31:58.819Z"}}]}}}