{"id":"CVE-2022-41240","state":"PUBLISHED","title":"Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by atta","description":"Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti.","publishedAt":"2022-09-21T15:45:59.000Z","updatedAt":"2025-05-28T14:52:17.300Z","severity":{"score":5.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","source":"CISA-ADP"},"assigner":"jenkins","products":["Jenkins project Jenkins Walti Plugin"],"affected":[{"vendor":"Jenkins project","product":"Jenkins Walti Plugin","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.0.1","versionType":"custom"},{"version":"next of 1.0.1","status":"unknown","lessThan":"unspecified","versionType":"custom"}]}],"references":["https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:37.819Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/41xxx/CVE-2022-41240.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-41240","state":"PUBLISHED","datePublished":"2022-09-21T15:45:59.000Z","dateUpdated":"2025-05-28T14:52:17.300Z","assignerShortName":"jenkins","assignerOrgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateReserved":"2022-09-21T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti."}],"affected":[{"vendor":"Jenkins project","product":"Jenkins Walti Plugin","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.0.1","versionType":"custom"},{"version":"next of 1.0.1","status":"unknown","lessThan":"unspecified","versionType":"custom"}]}],"references":[{"url":"https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870","tags":["x_refsource_CONFIRM"]}],"providerMetadata":{"shortName":"jenkins","orgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateUpdated":"2023-10-24T14:25:07.968Z"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"jenkinsci-cert@googlegroups.com","ID":"CVE-2022-41240","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Jenkins Walti Plugin","version":{"version_data":[{"version_affected":"<=","version_value":"1.0.1"},{"version_affected":"?>","version_value":"1.0.1"}]}}]},"vendor_name":"Jenkins project"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870","refsource":"CONFIRM","url":"https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.jenkins.io/security/advisory/2022-09-21/#SECURITY-1870","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T12:35:49.691Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"CHANGED","version":"3.1","baseScore":5.4,"attackVector":"NETWORK","baseSeverity":"MEDIUM","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","integrityImpact":"LOW","userInteraction":"REQUIRED","attackComplexity":"LOW","availabilityImpact":"NONE","privilegesRequired":"LOW","confidentialityImpact":"LOW"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-05-28T14:52:04.569839Z","id":"CVE-2022-41240","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","type":"CWE","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-28T14:52:17.300Z"}}]}}}