{"id":"CVE-2022-3991","state":"PUBLISHED","title":"Photospace Gallery <= 2.3.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting","description":"The Photospace Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its settings parameters saved via the update() function in versions up to, and including, 2.3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2022-11-29T20:43:32.624Z","updatedAt":"2026-04-08T16:52:27.342Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["deanoakley Photospace Gallery"],"affected":[{"vendor":"deanoakley","product":"Photospace Gallery","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.3.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/51212d87-8723-4ba7-8fa4-78912a56385f?source=cve","https://plugins.trac.wordpress.org/browser/photospace/trunk/photospace.php#L87","https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3991"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:32.060Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/3xxx/CVE-2022-3991.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-3991","state":"PUBLISHED","datePublished":"2022-11-29T20:43:32.624Z","dateUpdated":"2026-04-08T16:52:27.342Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","requesterUserId":"8d345d3f-a59e-4410-a440-fac6e918fcfc","dateReserved":"2022-11-14T15:44:27.765Z"},"containers":{"cna":{"title":"Photospace Gallery <= 2.3.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Photospace Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its settings parameters saved via the update() function in versions up to, and including, 2.3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"deanoakley","product":"Photospace Gallery","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.3.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/51212d87-8723-4ba7-8fa4-78912a56385f?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/photospace/trunk/photospace.php#L87"},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3991"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:52:27.342Z"},"credits":[{"lang":"en","type":"finder","value":"Marco Wotschka"}],"timeline":[{"time":"2022-09-13T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2022-11-14T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://plugins.trac.wordpress.org/browser/photospace/trunk/photospace.php#L87","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3991","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T01:27:53.729Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-23T20:48:43.622160Z","id":"CVE-2022-3991","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-23T20:48:47.703Z"}}]}}}