{"id":"CVE-2022-39334","state":"PUBLISHED","title":"nextcloudcmd incorrectly trusts bad TLS certificates","description":"Nextcloud also ships a CLI utility called nextcloudcmd which is sometimes used for automated scripting and headless servers. Versions of nextcloudcmd prior to 3.6.1 would incorrectly trust invalid TLS certificates, which may enable a Man-in-the-middle attack that exposes sensitive data or credentials to a network attacker. This affects the CLI only. It does not affect the standard GUI desktop Nextcloud clients, and it does not affect the Nextcloud server.","publishedAt":"2022-11-25T00:00:00.000Z","updatedAt":"2025-11-03T18:08:05.597Z","severity":{"score":3.9,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["nextcloud security-advisories"],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 3.6.1","status":"affected"}]}],"references":["https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv","https://github.com/nextcloud/desktop/issues/4927","https://github.com/nextcloud/desktop/pull/5022","https://hackerone.com/reports/1699740","https://lists.debian.org/debian-lts-announce/2025/09/msg00018.html"],"weaknesses":["CWE-295"],"ingestedAt":"2026-10-29T19:50:29.496Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/39xxx/CVE-2022-39334.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-39334","state":"PUBLISHED","datePublished":"2022-11-25T00:00:00.000Z","dateUpdated":"2025-11-03T18:08:05.597Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-09-02T00:00:00.000Z"},"containers":{"cna":{"title":"nextcloudcmd incorrectly trusts bad TLS certificates","descriptions":[{"lang":"en","value":"Nextcloud also ships a CLI utility called nextcloudcmd which is sometimes used for automated scripting and headless servers. Versions of nextcloudcmd prior to 3.6.1 would incorrectly trust invalid TLS certificates, which may enable a Man-in-the-middle attack that exposes sensitive data or credentials to a network attacker. This affects the CLI only. It does not affect the standard GUI desktop Nextcloud clients, and it does not affect the Nextcloud server."}],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 3.6.1","status":"affected"}]}],"references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv"},{"url":"https://github.com/nextcloud/desktop/issues/4927"},{"url":"https://github.com/nextcloud/desktop/pull/5022"},{"url":"https://hackerone.com/reports/1699740"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","attackVector":"LOCAL","attackComplexity":"LOW","privilegesRequired":"LOW","userInteraction":"REQUIRED","scope":"UNCHANGED","confidentialityImpact":"LOW","integrityImpact":"LOW","availabilityImpact":"NONE","baseScore":3.9,"baseSeverity":"LOW"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-295","type":"CWE","lang":"en","description":"CWE-295: Improper Certificate Validation"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2023-03-06T00:00:00.000Z"},"source":{"advisory":"GHSA-82xx-98xv-4jxv","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv","tags":["x_transferred"]},{"url":"https://github.com/nextcloud/desktop/issues/4927","tags":["x_transferred"]},{"url":"https://github.com/nextcloud/desktop/pull/5022","tags":["x_transferred"]},{"url":"https://hackerone.com/reports/1699740","tags":["x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2025/09/msg00018.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T18:08:05.597Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-22T15:40:45.580603Z","id":"CVE-2022-39334","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-22T15:59:53.227Z"}}]}}}