{"id":"CVE-2022-39295","state":"PUBLISHED","title":"Improper Neutralization of Alternate XSS Syntax in Knowage-Server","description":"Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.","publishedAt":"2022-10-13T00:00:00.000Z","updatedAt":"2025-04-22T17:18:42.596Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["KnowageLabs Knowage-Server"],"affected":[{"vendor":"KnowageLabs","product":"Knowage-Server","versions":[{"version":">= 6.0, < 7.4.22","status":"affected"},{"version":">= 8.0, < 8.0.9","status":"affected"}]}],"references":["https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw","https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206"],"weaknesses":["CWE-87","CWE-79"],"ingestedAt":"2026-10-29T19:50:29.496Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/39xxx/CVE-2022-39295.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-39295","state":"PUBLISHED","datePublished":"2022-10-13T00:00:00.000Z","dateUpdated":"2025-04-22T17:18:42.596Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-09-02T00:00:00.000Z"},"containers":{"cna":{"title":"Improper Neutralization of Alternate XSS Syntax in Knowage-Server","descriptions":[{"lang":"en","value":"Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds."}],"affected":[{"vendor":"KnowageLabs","product":"Knowage-Server","versions":[{"version":">= 6.0, < 7.4.22","status":"affected"},{"version":">= 8.0, < 8.0.9","status":"affected"}]}],"references":[{"url":"https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw"},{"url":"https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"CHANGED","confidentialityImpact":"LOW","integrityImpact":"LOW","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-87","type":"CWE","lang":"en","description":"CWE-87: Improper Neutralization of Alternate XSS Syntax"}]},{"descriptions":[{"cweId":"CWE-79","type":"CWE","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2022-10-13T00:00:00.000Z"},"source":{"advisory":"GHSA-f2gr-6h9j-rwcw","discovery":"UNKNOWN"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw","tags":["x_transferred"]},{"url":"https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T12:00:43.794Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-22T15:43:36.448157Z","id":"CVE-2022-39295","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-22T17:18:42.596Z"}}]}}}