{"id":"CVE-2022-3708","state":"PUBLISHED","title":"Web Stories <= 1.24.0 - Server Side Request Forgery","description":"The Web Stories plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including 1.24.0 due to insufficient validation of URLs supplied via the 'url' parameter found via the /v1/hotlink/proxy REST API Endpoint. This makes it possible for authenticated users to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","publishedAt":"2022-10-28T18:58:21.842Z","updatedAt":"2026-04-08T17:01:48.973Z","severity":{"score":9.6,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["google Web Stories"],"affected":[{"vendor":"google","product":"Web Stories","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.24.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/7817a840-325a-4709-8374-84bb32d98d0e?source=cve","https://wordpress.org/plugins/web-stories","https://github.com/GoogleForCreators/web-stories-wp/compare/v1.24.0...v1.25.0","https://github.com/GoogleForCreators/web-stories-wp/commit/3ad2099f95155d658624ffac2e34ce0da739e34b","https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3708"],"weaknesses":["CWE-918"],"ingestedAt":"2026-10-29T19:50:32.060Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/3xxx/CVE-2022-3708.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-3708","state":"PUBLISHED","datePublished":"2022-10-28T18:58:21.842Z","dateUpdated":"2026-04-08T17:01:48.973Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","requesterUserId":"8d345d3f-a59e-4410-a440-fac6e918fcfc","dateReserved":"2022-10-26T21:31:29.199Z"},"containers":{"cna":{"title":"Web Stories <= 1.24.0 - Server Side Request Forgery","descriptions":[{"lang":"en","value":"The Web Stories plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including 1.24.0 due to insufficient validation of URLs supplied via the 'url' parameter found via the /v1/hotlink/proxy REST API Endpoint. This makes it possible for authenticated users to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services."}],"affected":[{"vendor":"google","product":"Web Stories","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.24.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7817a840-325a-4709-8374-84bb32d98d0e?source=cve"},{"url":"https://wordpress.org/plugins/web-stories"},{"url":"https://github.com/GoogleForCreators/web-stories-wp/compare/v1.24.0...v1.25.0"},{"url":"https://github.com/GoogleForCreators/web-stories-wp/commit/3ad2099f95155d658624ffac2e34ce0da739e34b"},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3708"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N","baseScore":9.6,"baseSeverity":"CRITICAL"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-918","lang":"en","description":"CWE-918 Server-Side Request Forgery (SSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:01:48.973Z"},"credits":[{"lang":"en","type":"finder","value":"Aymen Borgi"}],"timeline":[{"time":"2022-10-26T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7817a840-325a-4709-8374-84bb32d98d0e?source=cve","tags":["x_transferred"]},{"url":"https://wordpress.org/plugins/web-stories","tags":["x_transferred"]},{"url":"https://github.com/GoogleForCreators/web-stories-wp/compare/v1.24.0...v1.25.0","tags":["x_transferred"]},{"url":"https://github.com/GoogleForCreators/web-stories-wp/commit/3ad2099f95155d658624ffac2e34ce0da739e34b","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3708","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T01:20:57.117Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T13:14:07.288549Z","id":"CVE-2022-3708","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-918","type":"CWE","lang":"en","description":"CWE-918 Server-Side Request Forgery (SSRF)"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-05T12:57:12.593Z"}}]}}}