{"id":"CVE-2022-35925","state":"PUBLISHED","title":"Missing rate limit in Authentication in bookwyrm","description":"BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.","publishedAt":"2022-08-02T20:15:15.000Z","updatedAt":"2025-04-22T17:43:24.043Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["bookwyrm-social bookwyrm"],"affected":[{"vendor":"bookwyrm-social","product":"bookwyrm","versions":[{"version":"< 0.4.5","status":"affected"}]}],"references":["https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw","https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/","https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f"],"weaknesses":["CWE-287"],"ingestedAt":"2026-10-29T19:50:17.761Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/35xxx/CVE-2022-35925.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-35925","state":"PUBLISHED","datePublished":"2022-08-02T20:15:15.000Z","dateUpdated":"2025-04-22T17:43:24.043Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-07-15T00:00:00.000Z"},"containers":{"cna":{"title":"Missing rate limit in Authentication in bookwyrm","descriptions":[{"lang":"en","value":"BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually."}],"affected":[{"vendor":"bookwyrm-social","product":"bookwyrm","versions":[{"version":"< 0.4.5","status":"affected"}]}],"references":[{"url":"https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw","tags":["x_refsource_CONFIRM"]},{"url":"https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/","tags":["x_refsource_MISC"]},{"url":"https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5.3,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","description":"CWE-287: Improper Authentication","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-08-02T20:15:15.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-jvp3-mqv8-5rjw","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-35925","STATE":"PUBLIC","TITLE":"Missing rate limit in Authentication in bookwyrm"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"bookwyrm","version":{"version_data":[{"version_value":"< 0.4.5"}]}}]},"vendor_name":"bookwyrm-social"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5.3,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-287: Improper Authentication"}]}]},"references":{"reference_data":[{"name":"https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw","refsource":"CONFIRM","url":"https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw"},{"name":"https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/","refsource":"MISC","url":"https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/"},{"name":"https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f","refsource":"MISC","url":"https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f"}]},"source":{"advisory":"GHSA-jvp3-mqv8-5rjw","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T09:51:59.095Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-22T15:39:58.640517Z","id":"CVE-2022-35925","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-22T17:43:24.043Z"}}]}}}