{"id":"CVE-2022-34791","state":"PUBLISHED","title":"Jenkins Validating Email Parameter Plugin 1.10 and earlier does not escape the name and description of its parameter type, resulting in a stored cross-site scripting (XSS) vulnerab","description":"Jenkins Validating Email Parameter Plugin 1.10 and earlier does not escape the name and description of its parameter type, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.","publishedAt":"2022-06-30T17:47:15.000Z","updatedAt":"2024-08-03T09:22:10.693Z","severity":null,"assigner":"jenkins","products":["Jenkins project Jenkins Validating Email Parameter Plugin"],"affected":[{"vendor":"Jenkins project","product":"Jenkins Validating Email Parameter Plugin","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.10","versionType":"custom"},{"version":"next of 1.10","status":"unknown","lessThan":"unspecified","versionType":"custom"}]}],"references":["https://www.jenkins.io/security/advisory/2022-06-30/#SECURITY-2165"],"weaknesses":[],"ingestedAt":"2026-10-29T19:50:14.780Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/34xxx/CVE-2022-34791.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-34791","state":"PUBLISHED","datePublished":"2022-06-30T17:47:15.000Z","dateUpdated":"2024-08-03T09:22:10.693Z","assignerShortName":"jenkins","assignerOrgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateReserved":"2022-06-29T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Jenkins Validating Email Parameter Plugin 1.10 and earlier does not escape the name and description of its parameter type, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission."}],"affected":[{"vendor":"Jenkins project","product":"Jenkins Validating Email Parameter Plugin","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"1.10","versionType":"custom"},{"version":"next of 1.10","status":"unknown","lessThan":"unspecified","versionType":"custom"}]}],"references":[{"url":"https://www.jenkins.io/security/advisory/2022-06-30/#SECURITY-2165","tags":["x_refsource_CONFIRM"]}],"providerMetadata":{"shortName":"jenkins","orgId":"39769cd5-e6e2-4dc8-927e-97b3aa056f5b","dateUpdated":"2023-10-24T14:23:20.783Z"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"jenkinsci-cert@googlegroups.com","ID":"CVE-2022-34791","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Jenkins Validating Email Parameter Plugin","version":{"version_data":[{"version_affected":"<=","version_value":"1.10"},{"version_affected":"?>","version_value":"1.10"}]}}]},"vendor_name":"Jenkins project"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Jenkins Validating Email Parameter Plugin 1.10 and earlier does not escape the name and description of its parameter type, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://www.jenkins.io/security/advisory/2022-06-30/#SECURITY-2165","refsource":"CONFIRM","url":"https://www.jenkins.io/security/advisory/2022-06-30/#SECURITY-2165"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.jenkins.io/security/advisory/2022-06-30/#SECURITY-2165","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T09:22:10.693Z"}}]}}}