{"id":"CVE-2022-34656","state":"PUBLISHED","title":"WordPress Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 - Authenticated Cross-Site Scripting (XSS) vulnerability","description":"Authenticated (admin+) Cross-Site Scripting (XSS) vulnerability in wpdevart Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 at WordPress.","publishedAt":"2022-09-06T17:18:54.693Z","updatedAt":"2026-04-28T16:07:44.590Z","severity":{"score":4.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["wpdevart Poll, Survey, Questionnaire and Voting system (WordPress plugin)"],"affected":[{"vendor":"wpdevart","product":"Poll, Survey, Questionnaire and Voting system (WordPress plugin)","versions":[{"version":"<= 1.7.4","status":"affected","lessThanOrEqual":"1.7.4","versionType":"custom"}]}],"references":["https://patchstack.com/database/vulnerability/polls-widget/wordpress-poll-survey-questionnaire-and-voting-system-plugin-1-7-4-authenticated-cross-site-scripting-xss-vulnerability/_s_id=cve","https://wordpress.org/plugins/polls-widget/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:14.780Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/34xxx/CVE-2022-34656.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-34656","state":"PUBLISHED","datePublished":"2022-09-06T17:18:54.693Z","dateUpdated":"2026-04-28T16:07:44.590Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2022-07-22T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 - Authenticated Cross-Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Authenticated (admin+) Cross-Site Scripting (XSS) vulnerability in wpdevart Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 at WordPress."}],"affected":[{"vendor":"wpdevart","product":"Poll, Survey, Questionnaire and Voting system (WordPress plugin)","versions":[{"version":"<= 1.7.4","status":"affected","lessThanOrEqual":"1.7.4","versionType":"custom"}]}],"references":[{"url":"https://patchstack.com/database/vulnerability/polls-widget/wordpress-poll-survey-questionnaire-and-voting-system-plugin-1-7-4-authenticated-cross-site-scripting-xss-vulnerability/_s_id=cve","tags":["x_refsource_CONFIRM"]},{"url":"https://wordpress.org/plugins/polls-widget/","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:07:44.590Z"},"credits":[{"lang":"en","value":"Vulnerability discovered by Kim Jong Min - Universe (Patchstack Alliance)"}],"datePublic":"2022-08-25T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"audit@patchstack.com","DATE_PUBLIC":"2022-08-25T15:37:00.000Z","ID":"CVE-2022-34656","STATE":"PUBLIC","TITLE":"WordPress Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 - Authenticated Cross-Site Scripting (XSS) vulnerability"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Poll, Survey, Questionnaire and Voting system (WordPress plugin)","version":{"version_data":[{"version_affected":"<=","version_name":"<= 1.7.4","version_value":"1.7.4"}]}}]},"vendor_name":"wpdevart"}]}},"credit":[{"lang":"eng","value":"Vulnerability discovered by Kim Jong Min - Universe (Patchstack Alliance)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Authenticated (admin+) Cross-Site Scripting (XSS) vulnerability in wpdevart Poll, Survey, Questionnaire and Voting system plugin <= 1.7.4 at WordPress."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://patchstack.com/database/vulnerability/polls-widget/wordpress-poll-survey-questionnaire-and-voting-system-plugin-1-7-4-authenticated-cross-site-scripting-xss-vulnerability/_s_id=cve","refsource":"CONFIRM","url":"https://patchstack.com/database/vulnerability/polls-widget/wordpress-poll-survey-questionnaire-and-voting-system-plugin-1-7-4-authenticated-cross-site-scripting-xss-vulnerability/_s_id=cve"},{"name":"https://wordpress.org/plugins/polls-widget/","refsource":"CONFIRM","url":"https://wordpress.org/plugins/polls-widget/"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://patchstack.com/database/vulnerability/polls-widget/wordpress-poll-survey-questionnaire-and-voting-system-plugin-1-7-4-authenticated-cross-site-scripting-xss-vulnerability/_s_id=cve","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://wordpress.org/plugins/polls-widget/","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T09:15:15.696Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-20T19:26:00.205094Z","id":"CVE-2022-34656","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-20T20:09:06.576Z"}}]}}}