{"id":"CVE-2022-34158","state":"PUBLISHED","title":"User Group Privilege Escalation","description":"A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.","publishedAt":"2022-08-04T06:16:11.000Z","updatedAt":"2024-08-03T08:16:17.225Z","severity":null,"assigner":"apache","products":["Apache Software Foundation Apache JSPWiki"],"affected":[{"vendor":"Apache Software Foundation","product":"Apache JSPWiki","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"Apache JSPWiki up to 2.11.2","versionType":"custom"}]}],"references":["https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158"],"weaknesses":[],"ingestedAt":"2026-10-29T19:50:14.780Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/34xxx/CVE-2022-34158.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-34158","state":"PUBLISHED","datePublished":"2022-08-04T06:16:11.000Z","dateUpdated":"2024-08-03T08:16:17.225Z","assignerShortName":"apache","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateReserved":"2022-06-20T00:00:00.000Z"},"containers":{"cna":{"title":"User Group Privilege Escalation","descriptions":[{"lang":"en","value":"A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page."}],"affected":[{"vendor":"Apache Software Foundation","product":"Apache JSPWiki","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"Apache JSPWiki up to 2.11.2","versionType":"custom"}]}],"references":[{"url":"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158","tags":["x_refsource_MISC"]}],"metrics":[{"other":{"content":{"other":"critical"},"type":"unknown"}}],"problemTypes":[{"descriptions":[{"description":"CSRF group privilege escalation","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"apache","dateUpdated":"2022-08-04T06:16:11.000Z","orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09"},"credits":[{"lang":"en","value":"This issue was discovered by Huiseong Seo (t0rchwo0d), <awdr1624AT gmail DOT com>"}],"source":{"discovery":"UNKNOWN"},"workarounds":[{"lang":"en","value":"Apache JSPWiki users should upgrade to 2.11.3 or later."}],"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@apache.org","ID":"CVE-2022-34158","STATE":"PUBLIC","TITLE":"User Group Privilege Escalation"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Apache JSPWiki","version":{"version_data":[{"version_affected":"<=","version_value":"Apache JSPWiki up to 2.11.2"}]}}]},"vendor_name":"Apache Software Foundation"}]}},"credit":[{"lang":"eng","value":"This issue was discovered by Huiseong Seo (t0rchwo0d), <awdr1624AT gmail DOT com>"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":[{"other":"critical"}],"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CSRF group privilege escalation"}]}]},"references":{"reference_data":[{"name":"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158","refsource":"MISC","url":"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158"}]},"source":{"discovery":"UNKNOWN"},"work_around":[{"lang":"en","value":"Apache JSPWiki users should upgrade to 2.11.3 or later."}]}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T08:16:17.225Z"}}]}}}