{"id":"CVE-2022-3240","state":"PUBLISHED","title":"Follow Me Plugin <= 3.1.1 - Cross-Site Request Forgery to Cross-Site Scripting","description":"The \"Follow Me Plugin\" plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.1.1. This is due to missing nonce validation on the FollowMeIgniteSocialMedia_options_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious JavaScript via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2022-11-15T13:25:57.082Z","updatedAt":"2026-04-08T16:42:33.231Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["brian-chappell Follow Me Plugin"],"affected":[{"vendor":"brian-chappell","product":"Follow Me Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/25fab7b3-59ce-44ca-83fa-bd25b7f31af0?source=cve","https://plugins.trac.wordpress.org/browser/follow-me/trunk/follow-me.php#L261","https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3240"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:50:32.060Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/3xxx/CVE-2022-3240.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-3240","state":"PUBLISHED","datePublished":"2022-11-15T13:25:57.082Z","dateUpdated":"2026-04-08T16:42:33.231Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","requesterUserId":"8d345d3f-a59e-4410-a440-fac6e918fcfc","dateReserved":"2022-09-19T16:36:05.563Z"},"containers":{"cna":{"title":"Follow Me Plugin <= 3.1.1 - Cross-Site Request Forgery to Cross-Site Scripting","descriptions":[{"lang":"en","value":"The \"Follow Me Plugin\" plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.1.1. This is due to missing nonce validation on the FollowMeIgniteSocialMedia_options_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious JavaScript via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"brian-chappell","product":"Follow Me Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.1.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/25fab7b3-59ce-44ca-83fa-bd25b7f31af0?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/follow-me/trunk/follow-me.php#L261"},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3240"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:42:33.231Z"},"credits":[{"lang":"en","type":"finder","value":"Marco Wotschka"}],"timeline":[{"time":"2022-11-14T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://plugins.trac.wordpress.org/browser/follow-me/trunk/follow-me.php#L261","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3240","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T01:00:10.849Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-31T18:25:37.161668Z","id":"CVE-2022-3240","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-31T18:25:44.342Z"}}]}}}